[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Tor Browser permission issues

Please someone help me I can’t access the tor browser on the workstation iam new to whonix so excuse my lack of knowledge please.
Please someone help me on that!!! I will pay pal anyone 20 bucks if someone can solve this for me !!!

It says: Tor Browser permission issues. it tells me to open up the console and type in command but when I do that then it says:

default user account: user

default password: changeme

Type: “whonix” for help.

uwt INFO: Stream isolation for some applications enabled. uwt / torsocks will be automatically prepended to some commands. What is that? See:

user@host:~$ sudo chown --recursive “user”:“user” “/home/user/.tb/tor-browser”

[sudo] password for user:

user@host:~$

user@host:~$ user@host:~$ sudo chown --recursive “user”:“user” “/home/user/.tb/tor-browser”

Could not find the database of available applications, run update-command-not-found as root to fix this

Sorry, command-not-found has crashed! Please file a bug report at:

censored out can’t include no links
Please include the following information with the report:

command-not-found version: 0.3

Python version: 3.7.3 final 0

Distributor ID: Debian

Description: Debian GNU/Linux 10 (buster)

Release: 10

Codename: buster

Exception information:

local variable ‘cnf’ referenced before assignment

Traceback (most recent call last):

File “/usr/share/command-not-found/CommandNotFound/util.py”, line 23, in crash_guard

callback()

File “/usr/lib/command-not-found”, line 93, in main

if not cnf.advise(args[0], options.ignore_installed) and not options.no_failure_msg:

UnboundLocalError: local variable ‘cnf’ referenced before assignment

user@host:~$

sudo chown --recursive user:user /home/user

I am having the same issue, no change after opening terminal and running sudo chown command.

is there anything else that i can try to fix the issue, Whonix is dead in the water for me otherwise. i appreciate any help that can be given.

Edit: Found the solution (thank you Patrick) for next steps on another thread:

" There’s no need to panic. This works well for most users for a very long time.

Possibly you’re doing something which you shouldn’t be doing. If something doesn’t work, then often using sudo / root isn’t an option either. It often won’t - unless indicated - solve the issue but cause permission issues.

Could you please run the following command and post the output here? Probably won’t work but good for debugging.

cp --verbose --recursive --no-clobber "/var/cache/tb-binary/.tb/tor-browser" "/home/user/.tb/tor-browser"

Next, delete /var/cache/tb-binary folder. There shouldn’t be anything there unless you know you modified that folder.

sudo rm -r /var/cache/tb-binary

Also delete this /home/user/.tb folder.

sudo rm -r /home/user/.tb

And delete /home/user/.cache/tb folder.

sudo rm -r /home/user/.cache/tb

Then this should be fixed. Does it work now?

Does it break after the while? If yes, what kind of modifications are you making to Tor Browser / running sudo / root inside browser folder?"

Please use forum quote function / link to original forum post.

will do in the future/usually do… i lost the original post and thought posting the info outside of best practices was better than not.

regardless, thanks again for staying active and helping so many in the community.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]