[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Tor Browser issue

after upgrading to tor browser 9 , my TB failed to start properly just black screen and nothing else

Welcome to Whonix forums and thank you for your question!

Not clear if this can be debugged / fixed.


To re-install Tor Browser with Tor Browser data loss (loosing browser profile, bookmarks, …):

Use Tor Browser Downloader (by Whonix Developers) as per:

https://www.whonix.org/wiki/Tor_Browser#Update_Tor_Browser


To debug:

Try to start from command line:

https://www.whonix.org/wiki/Tor_Browser#From_the_Command_Line

Try to start in debugging mode:

https://www.whonix.org/wiki/Tor_Browser#From_the_Command_Line

And post output here.

problem almost solved
edited logs to make thread a better look

i am sorry my original login not allow me to post or reply
regards

Using AppArmor?
Whonix version?
Tor Browser version?


If using AppArmor:

sudo journalctl | grep -i denied
1 Like

It’s probably an issue with apparmor or firejail if you’re using those.

1 Like

problem almost solved
logs edited for making thread better look !

It says it’s being denied access to /dev/dri/ and /dev/shm/org.mozilla.ipc.* but the Tor Browser apparmor profile grants access to both of those.

https://github.com/Whonix/apparmor-profile-torbrowser/blob/master/etc/apparmor.d/home.tor-browser.firefox#L44

https://github.com/Whonix/apparmor-profile-torbrowser/blob/master/etc/apparmor.d/home.tor-browser.firefox#L48

Did you make any modifications to the profile?

What does running sudo aa-logprof give you?

2 Likes

Output of

dpkg -l | grep torbrowser

?

1 Like

I am extremly sorry i have to make another login , first one not allow to reply or post and now second one is giving error on posting that new user can only post 3 times in a topic … appology

Thanks you so much brother
i didnt change if i remeber correctly but i reverted whole profile file to given link

and it start working

and

user@host:~$ sudo aa-logprof

ERROR: Values added to a non-existing variable @{HOMEDIRS}: /rw/home/ in tunables/home.d/live-mode

But things working

ii apparmor-profile-torbrowser 3:4.8-1 all AppArmor profile for The Tor Browser Bundle (TBB)
ii tb-default-browser 3:2.2-1 all Configures system to use /usr/bin/torbrowser as default browser

You probably didn’t update the apparmor profile in a while then.

This issue was fixed a while ago. You need to update.

1 Like

Thanks you so much for kind help , should i update apparmor from tester repo ? or manually update all profiles

You shouldn’t use the testing repos unless you want to test new Whonix features.

Just update everything by running

sudo apt-get-update-plus dist-upgrade
1 Like

wonderful support is enough reason to support and donate whonix
Thanks you brothers

1 Like
1 Like

It would be better to use

owner /run/user/[0-9]*/dconf/ rw,
owner /run/user/[0-9]*/dconf/** rw,

instead. It’s much more strict.

1 Like

I see some denied messages too but none that prevent Tor Browser from
starting.

Did you upgrade?

I remember some listed there which should be fixed already.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]