[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Tor Browser in Whonix blocks JavaScript (only when started for the first time) and in DispVMs

thanks for the fast reply.

Yes I see that function in /usr/bin/torbrowser, but the problem is still the same.

What if you start konsole first, wait a bit, and then start Tor Browser from command line torbrowser?

sleep 30 && torbrowser

is not any better.

I’ve noticed this too and have been following along with the same results. If I change the security slider to a different setting then back to Standard, Javascript starts working. This might be a TBB bug, not Whonix, but I haven’t tested further.

1 Like

I don’t think this is a vanilla torbrowser bug since it only happens in whonix - never with vanilla torbrowser.

Check whonix-ws-dvm.

in dom0.

qvm-start whonix-ws-14-dvm konsole

Do you have a /home/user/.tb folder there? There shouldn’t be one.

Shut down whonix-ws-14-dvm. Start whonix-ws-14 TemplateVM. Run update-torbrowser to get a new copy.


Can you compare a prestine Tor Browser folder from non-Whonix with the one in DispVM?

Or copy a Tor Browser folder form non-Whonix to a Whonix VM and still reproduce?

qvm-start whonix-ws-14-dvm konsole

you meant qvm-run there.

Do you have a /home/user/.tb folder there? There shouldn’t be
one.

There is no such folder (as expected)

ls ~/.tb
ls: cannot access '/home/user/.tb': No such file or directory

Run update-torbrowser to get a new copy.

done, problem still persists.

Can you compare a prestine Tor Browser folder from non-Whonix with the one in DispVM?

diff -r tor-browser_en-US/ .tb/tor-browser
no output (no differences)

Or copy a Tor Browser folder form non-Whonix to a Whonix VM and still reproduce?

mv  .tb/tor-browser  .tor/tor-browser-old2
mv tor-browser_en-US/ .tb/tor-browser
torbrowser

-> reproducable as expected since the folders are identical

1 Like

any update on this issue?

No.

With torbrowser 8.5 this issue became a lot more annoying since the NoScript button is no longer exposed by default and you have to go to Add-ons -> Preferences -> …
to disable it.

Any update on this?

phabricator via Whonix Forum:

Any update on this?

Not that I know.

For reference:

Is this issues expected to be solved in Whonix 15?

If there was one it should now be fixed in Whonix 15 and with later upgrades this will be further solidified. See tb-updater git commit history.

There is also a lot going on here outside of Whonix control, meaning The Tor Project deciding to

  • not enable to set noscript to blocking of all scripts globally by default,
  • not persist noscript per-site settings by default,
  • remove noscript from Tor Browser menu bar by default

See also this very comment:

https://github.com/QubesOS/qubes-issues/issues/5102#issuecomment-508726094

Generally:

iprid23:

@adrelanos
Does this imply that the expected behaviour is for NoScript to not block the scripts?

Defaults are up to The Tor Project. See also:

https://www.whonix.org/wiki/Tor_Browser#NoScript

Or so it says in the Whonix issue?

If there was one it should now be fixed in Whonix 15 and with later
upgrades this will be further solidified. See tb-updater git commit history.

If so, how is this behaviour controlled? I’d prefer to have it block all scripts by default on every Disposable VM start.

Tor Browser by The Tor Project does not provide an environment variable
or documentation on how to enable blocking of all scripts upon start of
Tor Browser. Neither a ticket against Tor Project exists.

See also:

https://www.whonix.org/wiki/Tor_Browser#Tor_Browser_Bundle_versus_Whonix_Tor_Browser

https://www.whonix.org/wiki/Tor_Browser#Tor_Browser_Functionality_on_Different_Platforms

Also, is there a bug filled for the disappearence of the NoScript button in the browser menu bar?

Decision by Tor Project.

It’s really annoying have it drag it from Customizations each time you use a Disposable VM.

Customizations discouraged by Tor Project, documented here:

https://www.whonix.org/wiki/Tor_Browser#NoScript_Custom_Setting_Persistence

This was reported upstream.

https://trac.torproject.org/projects/tor/ticket/31094

//cc @Patrick

1 Like

Thanks for noticing. Answered there just now.

Maybe the patch that fixed this issue is the cause?

https://trac.torproject.org/projects/tor/ticket/27401

Related:

https://trac.torproject.org/projects/tor/ticket/27411

1 Like

Great find! Pointed that out in the ticket.

https://trac.torproject.org/projects/tor/ticket/31094#comment:6

2 posts were split to a new topic: Tor Browser asks to set Security Slider to Maximum at every Qubes DispVM Startup

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]