[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

tor browser downloader install fail

Hi folks. I recently installed whonix gateway and workstation, no problems there. Tor diwnloaded during gateway installation but everytime I attempt to install to workstation it’s failing about halfway through stating it’s possibly a network issue or or something.

I’ve tried for 10 days solid now, and I’m due to volley my computer out the window. I’m newbie status and don’t know how to fix this, can anyone help me please?

I’m wet behind the ears with this kind of stuff so please explain as you would do to a 5 year old lol.

Whonix 12? Virtualbox images?

Not sure what that means. Gateway connected to Tor successfully? What does Whonixcheck say? (Type whonixcheck in a Terminal or use icon in app menu)

Sorry, I’m a newbie and learning the ropes.

Yes I have virtualbox installed with both whonix gateway and workstation installed.

I typed whonixcheck into gateway konsole and got the following info

I typed whonixcheck into workstation konsole and got following info

When I try to run tor in workstation it tells me I don’t have it installed, I then attempt to install it through the tor browser downloader.

I get to around halfway

And then get this message

Any ideas what I’m doing wrong?

Thanks for the details!

Looks like you’re doing everything right. Normally, I would just say to try again but if you’ve been trying for 10 days, not so sure. Do you have a very slow connection? When the Tor Browser Updater first launches, which version are you picking to download? I was able to successfully install 5.5.2, which is probably what you should be using.

It’s possible to download and set it up manually but doing it properly requires a lengthy walkthrough.

Your situation is not related to the other thread (not yet anyway).

  • Tor is the network that routes your traffic. Tor Browser is the web browser designed to use Tor. Tor Browser Bundle is Tor + Tor Browser.

  • If you press PrtScr, your host (Debian) will take a screenshot of your whole monitor and put the image in your Pictures directory. If you press RCtrl-E while in a VM window, you can take a screenshot of just the active VM.

  • Before you upload images, remember to clean the metadata from them by using Metadata Anonymisation Toolkit (MAT). (Appmenu -> System -> MAT) Don’t need to worry with Whonix.org but it’s always good to practice safe habits.

Thanks for the quick reply entropy

It’s 5.5.2, there are 2 more available but have (a) after them, so have a stuck with the default. My connection is ok, am using Ethernet and don’t have any other devices running.

Is there a link to the lengthy walkthrough? Or even a nudge in the right direction? I’m gutted I can’t get this to work

There are instructions here but they assume that you already have a working browser. Manually Download Tor Browser

The walkthrough is “lengthy” because I have to write it lol.

Copy/paste these commands, one at a time, in any Terminal (all in Workstation; as user, no sudo):

download

mkdir /home/user/.tb
cd /home/user/.tb
wget -c https://www.torproject.org/dist/torbrowser/5.5.2/tor-browser-linux32-5.5.2_en-US.tar.xz
wget -c https://www.torproject.org/dist/torbrowser/5.5.2/tor-browser-linux32-5.5.2_en-US.tar.xz.asc

verify

please read https://www.torproject.org/docs/verifying-signatures.html.en
fundamental security concept

gpg --recv-keys 0x93298290
gpg --fingerprint 0x93298290

confirm that ‘Key fingerprint’ matches:
EF6E 286D DA85 EA2A 4BA7 DE68 4E2C 6E87 9329 8290

gpg --verify tor-browser-linux32-5.5.2_en-US.tar.xz.asc

make sure that the output says “Good signature”. warning is expected - we haven’t certified that it’s trusted.

extract & clean up

bsdtar -xf tor-browser-linux32-5.5.2_en-US.tar.xz
mv tor-browser_en-US tor-browser
rm tor-browser-linux32-5.5.2_en-US.tar*

launch

your Tor Browser icon on the desktop and appmenu should work now.

1 Like

note: tar was changed to bsdtar (workstation doesn’t have xz-utils installed).

Went through entire process I’m not still says not installed

Can’t read your mind or your screen… Assuming there were no errors except launching shortcut, try this in Terminal:

/home/user/.tb/tor-browser/start-tor-browser

I know, I appreciate both your help and patience entropy, honestly im extremely thankful.

I tried that last line too, file doesn’t exist was error

Entropy, i made a mistake in the code, I’m up and running!!.

Going on 11 days at that, so I can’t thank you enough mate, honestly, even my wife is grateful cos I haven’t looked at her in all that time pmsl

Good to hear! Had to step away but I see you put an extra space before .tb. The files were being extracted to wrong directory. Always easier to copy/paste code. Still no idea why updater didn’t work. Anyway, happy browsing!

Yeah that was the problem, noob mistake I guess.

Not sure why installler didn’t work, although when I used the procedure you gave, the downloading of the files only took like maybe 5-8 minutes, the screenshot I provided showing the progress bar at halfway, that took about 1.5-2 hours to get halfway before I got the error message.

You’ve now got an idea how many hours I was at that lol, so I thank you again mate…

Next step, keepassx!!

I wasn’t able to login to my account so have made another, i hope this doesn’t breach rules of the forum, i thought the open and honest approach would be best…

Anyway, i purchased a new computer and began the entire install process again, but funnily enough, i’ve come across the same problem in that Tor Browser isn’t installed on workstation, the downloader does the same as last time, it gets halfway through and fails, as described in previous posts within this thread.

I attempted to use the advice/procedure mentioned by Entropy, but im getting a 404 error

mkdir /home/user/.tb No problem with this
cd /home/user/.tb No problem with this
wget -c https://www.torproject.org/dist/torbrowser/5.5.2/tor-browser-linux32-5.5.2_en-US.tar.xz This gives a 404 error
wget -c https://www.torproject.org/dist/torbrowser/5.5.2/tor-browser-linux32-5.5.2_en-US.tar.xz.asc This gives a 404 error

Obviously i haven’t progressed past this stage yet, could anyone advise please?

Many many thanks in advance

i think ive worked it out. 5.5.2 isn’t there anymore, have changed to 5.5.4 and its started, im assuming i’d just follow the same procedure/

Correct. 5.5.4 is the latest version of Tor Browser.


So you tried Tor Browser Downloader on 2 clean installs of VirtualBox Whonix-12 Workstation on 2 separate machines and both failed with progress bar approx 50%? (and wget works properly). That’s strange.

If you took a VB snapshot prior to manually installing Tor Browser, could you restore that snapshot and try running update-torbrowser in Konsole? Will provide more info about what’s going on…

Did you sudo apt-get update && sudo apt-get dist-upgrade before running Tor Browser Downloader?

Never mind about that. As long as there is distortion, there really is no problem.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]