[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Tor Bridges Help


#1

I followed all the steps for installation of bridges via qubes whonix shown on the whonix website here:

But when I get to the final step, namely:

Check Tor’s daemon status.
sudo service tor@default status
It should include a a message saying.
Active: active (running) since …

I get the following:

user@host:~$ sudo service tor@default status
● tor@default.service - Anonymizing overlay network for TCP
Loaded: loaded (/lib/systemd/system/tor@default.service; static)
Drop-In: /lib/systemd/system/tor@default.service.d
└─30_qubes.conf, 40_qubes.conf
Active: inactive (dead)
start condition failed at Wed 2017-09-27 02:47:31 UTC; 3min 37s ago
ConditionPathExists=/var/run/qubes-service/whonix-gateway was not met

Sep 27 02:47:31 host systemd[1]: Started Anonymizing overlay network for TCP.

Does this mean I didnt properly configure the bridge? If so, why am I not getting what the whonix site is saying I should get? Anything would help alot. Thanks in advance!


#2

Please don’t do it inside the whonix-gw TemplateVM, do it in the sys-whonix ProxyVM.


#3

Thanks Patrick,

I guess my confusion is that there are so many different VM’s - some labeled ServiceVM, some labeled TemplateVM Some labeled Domain, and then there are variations and colors of each.

I guess it would really help if you let me know which precise VM I apply the changes to in terminal, and which precise one I actually use to access the tor browser. Also, which one do I use to apply the bridges settings to? Having a hard time finding tutorials on this basic issue online. Anything would help. Thanks!


#4

HI @Jon

For Qubes-Whonix you make the changes in Whonix-Gateway Proxy VM (Commonly named ‘sys-whonix’) Apply all of the instructions to this VM.

This is stated in the Bridges instructions.


#5

Thanks patrick,

But still getting this message after I follow the instructions and then initiate the “whonix setup” portion of the instructions:

“returned exit code 3, which means tor does NOT work. Maybe your whonix-gateway has only one network card attached?,”

could this be because i conducted the instructions already in the WS? should i delete those?

Thanks!


#6

Hi @Jon

If you used the Bridge instructions in whonix-ws ( Template or appVM ) it would be a good idea to start fresh.

If you are confused on the terminology used in the instructions ( i.e. What is meant by Whonix-gateway, Whonix-workstation Templates; sys-whonix, anon-whonix VMs ) you could read over the Qubes/Install page. It may help clarify things a little for you.


#7

Edit for my last post: I failed to include the Qubes/Install page. My apologies for the mistake.

Could a moderator please delete this duplicate. Mistake in previous post has been corrected


#8

The gateway is independent from the workstation.

You still have to to it in sys-whonix - not in whonix-gw!


#9

0brand:

If you used the Bridge instructions in whonix-ws ( Template or appVM ) it would be a good idea to start fresh.

Doing it in a template requires sys-whonix behing deleted and recreated.
We don’t really recommend that but that may work. bind-dirs probably
makes this a confusing process.


#10

Hi @Patrick

By starting fresh I meant he should create and use a new workstation template or appvm. I should have been more specific. Sorry for being so vague.