[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Tor Bootstrapping Problem


#1

Recently, I reinstalled Whonix. It didn’t come with anon-whonix, so I made a substitute VM for myself to use as the Gateway Net-VM, and it didn’t come with Tor Browser, so I tried downloading Tor.

When I tried to download Tor Browser with sys-net as the NetVM, Tor could not connect to the control port. I then changed the NetVM to anon-whonix, and the error message that I received was “Tor Bootstrap Result: Whonixcheck gave up waiting”. My internet connection was working, and I do not reside in a censored area. I have retried Whonix Check several times, but I still get the error message: https://m.imgur.com/1Gut4Tz

I have also checked Arm to figure out the problem, but I don’t know how to configure anything in Arm, or any commands that I can use. When I opened Arm in anon-whonix, I saw this: http://imgur.com/N7KIRiq. I then tried to connect to Tor through Arm in whonix-gw, but my connection is refused because the Control Port is not enabled (http://imgur.com/mZARcAL).


#2

HI person

You should have Whonix set up like this:

 sys-net-> sys-firewall-> sys-whonix-> anon-whonix

Whereas sys-whonix VM is based on Whonix-gw Template; anon-whonix VM is based on Whonix-ws Template

This page has some helpful Qubes-Whonix links: :wink:

https://whonix.org/wiki/Qubes


#3

@person Welcome to the forums! I remember seeing your thread on qubes-users a couple days ago. You need to start from the very beginning and build up some basic understanding of how Qubes and Whonix work on a conceptual level - no need to get technical.

To address some of your errors:

  • you confuse template VMs with template-based VMs. Understand the first section of this: https://www.qubes-os.org/getting-started/

  • you are attempting to use trial and error to connect various components in ways that they were not meant to be. There is one and only one way to use Whonix. Read: https://www.whonix.org/wiki/Main_Page

  • whonix is designed to work for the vast majority of users without modification of configuration files. Do not tinker unless you know what you are doing!

Once you’ve understood the above, the following will make more sense:

A working Qubes-Whonix system is composed of a minimum of four VMs:

  1. template VM: whonix-gw
  2. template-based VM: sys-whonix (based on whonix-gw)
  3. template VM: whonix-ws
  4. template-based VM: anon-whonix (based on whonix-ws)

The template VMs are designed to hold clean root filesystems. That means the only commands you should run in a template VM are:
sudo apt-get update && sudo apt-get dist-upgrade and
sudo poweroff
(and sudo apt-get install <package> if needed)

sys-whonix is designed to run out-of-the-box. Only advanced users should modify it.

That leaves anon-whonix. This is your “work” VM where you run programs and save your data.


My suggestion to you is to remove all traces of Whonix from your system (assuming that there isn’t anything you need to save).

Run these commands in a dom0 Konsole to do so:

[user@dom0 ~]$ qvm-shutdown anon-whonix sys-whonix whonix-gw whonix-ws
[user@dom0 ~]$ qvm-remove anon-whonix
[user@dom0 ~]$ qvm-remove sys-whonix
[user@dom0 ~]$ sudo dnf remove qubes-template-whonix-gw qubes-template-whonix-ws

Then follow these instructions exactly: https://www.whonix.org/wiki/Qubes/Install

If those steps don’t work, then tell us precisely what the issue is. Do not start making random modifications.


#4

I added a sys-whonix VM, and this time I got both a Tor Bootstrap error message and a Tor Control Port error message: http://imgur.com/nCFQQ5C. I may have set the VM types for sys-whonix and anon-whonix to NetVM instead of ProxyVM, and the Qubes site recommended that I set it to ProxyVM. I also didn’t choose the right networking VMs, so it’s no wonder I got so many problems. After all, I’m relatively new to Whonix.

I decided to reinstall Whonix and follow the instructions on www.qubes-os.org/doc/whonix/install. Unfortunately, when the installation finished, I received a strange error message, and the templates did not appear.image


#5

Hi Person

sys-whonix is bases on Whonix-gw Template and is VM type ProxyVM. You can use this command to create the VM:

[user@dom0 ~]$ qvm-create -p -t whonix-gw -l red sys-whonix

anon-whonix is based on Whonix-ws Template and is VM type AppVM. You can use this command to create the VM.

[user@dom0~]$ qvm-create -t whonix-ws -l orange anon-whonix

It looks like you need to download the templates again. Not all of the packages were downloaded. Its hard for me to know for sure, I’m having a hard time seeing the text on your picture.


#6

I tried to install the templates again, but the same problem appeared.

“The downloaded packages were saved in cache until the next successful transaction. You can remove cached packages by executing “dnf clean packages”.
‘/usr/lib/qubes/qrexec-client-vm dom0 qubes.ReceiveUpdates /usr/lib/qubes/qfile-agent /var/lib/qubes/dom0-updates/packages/*.rpm’ failed with exit code 1!”


#7
  • Sorry to bounce you around, but this latest problem is a Qubes issue, and has nothing to do with Whonix. “Error installing templates on Qubes 3.2”. You’re much more likely to get good help when you ask the right people.

  • I don’t know enough about Qubes update scripts. The error doesn’t look like it’s caused by an interrupted download. Could it be invalid updateVM? insufficient disk space? invalid arguments? missing updates?

  • Instead of just the error message, it’s helpful to provide the full output including the command you typed (maybe the error was simply caused by a typo?)

  • Make sure dom0 and your updateVM are fully updated. (They should always be anyway).


#8

Today, there were new updates for dom0 that I installed. Apparently, this solved the previous error message. The problem I had was that the updates didn’t appear before today.


#10

Never mind. I believe I may have missed a step of the installation, and now I have the templates.

The thing is, I ran WhonixCheck on whonix-gw and everything was just fine, but when I ran WhonixCheck on whonix-ws, this happened.

However, Tor works on anon-whonix.


#11

Hi person

Glad to here you have Whonix installed and are able to connect to Tor! I’m not trying to overwhelm you but you should now proceed to the Post Install Advice.

https://whonix.org/wiki/Post_Install_Advice