[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

The workstation vmdk gets bigger and bigger

It’s not like im installing anything or downloading stuff but it grows constantly and is well over 10GB now
I believe it started at about 4GB?

Is that to be expected and why is that?

Not expected. Perhaps a file disk leak with temporary files?

Can you help analyzing this please?

baobab is a good tool

install:
sudo apt-get install baobab

start:
baobab

Run in a fresh image, then run after it has grown.

Also useful:
df -h

Note, when you created a big file or downloaded a big file, then delete it from the VM, the space will not be automatically freed up. Requires disk shrinking.

Baobab is a GUI application, it will make your image grow even more if you install this thing :smiley:

On a serious note, ncdu is a tiny ncurses utility that does pretty much the same.

Another trick that helps me finding where do files appear in my filesystem and which ones grow and eat up space is tree. Using

$ tree -a -n -s

periodically and redirecting the output produces files that can be compared nicely using diff.

Patrick by disk shrinking,does free disk space (bleachbit option) solve the problem?
And also ,if its possible to expand virtual disk from 100GB default to 150 or 200? Or this is only building option?

We don’t have great documentation about this. Created a ticket:
https://github.com/Whonix/Whonix/issues/173

Maybe as step one, but not on it’s own.

Something like this would be required:

(Need to convert to .vdi frist.)

(Need to convert to .vdi first. You do not have to convert back to .vmdk afterwards.)

The problem was a log file of 3rd party app that went crazy, 5gb lol

Now turns out shrinking is not trivial.
I’m following this tutorial, which seems to be the best and most fresh
http://dantwining.co.uk/2011/07/18/how-to-shrink-a-dynamically-expanding-guest-virtualbox-image/

but when I try to remount the main partition under recovery mode in read only (necessary for zerofree) i get
“mount -n -o remount,ro -t ext3 /dev/sda1 /” I get the error “mount: / is busy”

init 1 doesn’t help either.

so what should I stop in the case of whonix to be able to run that command and proceed with the tut?

Maybe mounting isn’t required. When you run “ls -la” you see, that the disk is already mounted in Debian recovery. Maybe try zerofree without that mount command. Have a backup (clone) of that VM in case anything goes wrong. Tell us if that worked.

This is being tracked here.

document vmdk disk shrinking and expanding
https://phabricator.whonix.org/T64

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]