[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

The repository does not have a release file


#1

Hi,

I’ve just upgraded from whonix 13 to 14 and trying to do a

sudo apt-get update && sudo apt-get dist-upgrade

This is the error I am getting

W: The repository ‘tor+http://deb.dds6qk…onion stretch release’ does not have a release file.

E: Failed to fetch tor+http://deb.dds6qk…onion/dists/stretch/main/bindary-amd64/packages 503 could not send data to remote server.

How do I solve this? I tried with --allow-unauthenticated but it didn’t solve my issue, also tried reboot.

Thanks in advance!

Edit: I am on Qubes 3.2


enable onion apt repository by default for Qubes /etc/apt/sources.list.d/qubes-r4.list
#2

Hi zerop

There are a couple possibilities:

  1. This could be a temporary issue due to a Tor exit relay or server failure that should resolve itself. Check if the network connection is functional by changing the Tor circuit and trying again. Running whonixcheck might also help to diagnose the problem.
  1. Since you just upgraded from Whonix 13 there could be various other issues going on here.

Could you please post the output of whonixcheck.

In sys-whonix konsole, run.

whonixcheck


#3

zerop:

I tried with --allow-unauthenticated

Insecure.


#4

Hi 0brand,

Thanks for your reply!

I tried updating today to check if it was resolved but it had not been resolved since yesterday. I then tried to change the tor circuit through Arm but wasn’t the fix neither. I ran whonixcheck on the terminal and this is my message:

[INFO] [whonixcheck] sys-whonix | Whonix-Gateway | whonix-gw Template-based ProxyVM | Thu Oct 18 13:45:41 UTC 2018
dmesg: read kernel buffer failed: Operation not permitted
[INFO] [whonixcheck] Connected to Tor.
[INFO] [whonixcheck] SocksPort Test: Testing Tor’s Socksport…
[INFO] [whonixcheck] SocksPort Test Result: Connected to Tor. IP: 54.36.189.105
[INFO] [whonixcheck] Whonix News Download: Checking for Whonix news and updates…
[WARNING] [whonixcheck] Whonix News Result:
X Outdated: Installed whonix-gateway-packages-dependencies 3.4-1 is outdated!
You should update. You can automatically update using Whonix’s internal updater. Please update using:
sudo apt-get update && sudo apt-get dist-upgrade
[INFO] [whonixcheck] Debian Package Update Check Result: apt-get reports that packages can be updated.
Please update your ‘whonix-gw’ TemplateVM.

  1. Open a TemplateVM terminal. (dom0 -> Start Menu -> Template: ‘whonix-gw’ -> Terminal)
  2. Update. Sudo apt-get update && sudo apt-get dist-upgrade
  3. Shutdown your TemplateVM. (dom0 -> Qubes VM Manager -> right click ‘whonix-gw’ -> Shutdown VM)
  4. Shutdown and restart this Template-based ProxyVM. (dom0 -> Qubes VM Manager -> right click ‘sys-whonix’ -> shutdown VM)

[INFO] [whonixcheck]Whonix APT repository: Enabled.

Edit: I used ‘‘sudo sysctl kernel.dmesg_restrict=0’’ to get rid of this error:
dmesg: read kernel buffer failed: Operation not permitted

Edit 2: I have now seemed to solve all issues except one. When I try to…

sudo apt-get update && sudo apt-get dist-upgrade

… in my whonix-gw-14 or whonix-ws-14 konsole I get this error:

W: The repository ‘tor-http://deb.dds6q… stretch Release’ does not have a Release file.

Is it because the link is down or something? Could I install it manually with a mirror link through another repository? I’m very new to this I should add!!


#6

Hi zerop

That looks like the Whonix APT repository. I’m curious as to what repo you have enabled. Could you please post the output of the following command.

cat /etc/apt/sources.list.d/whonix.list


#7

I have now typed the command in the whonix-gw-14 terminal.

cat /etc/apt/sources.list.d/whonix.list

The results were this:

Whonix /etc/apt/sources.list.d/whonix.list

This file has been automatically created by /usr/bin/whonix_repository.

If you make the manual changes to it, your changes get lost next time you run the whonix_repository tool.

You can convientiently manage this file, using the whonix_repository tool.

For any modifications (delete this file, use stable version, use testers version or use developer version), please run the whonix_repository tool.

Run:
Sudo whonix_repository

deb tor+http://deb.dds6qkxpwdeubwucdiaord2xgbbeyds25rbsgr73tbfpqpt4a6vjwsyd.onion stretch main
#deb-src tor+http://deb.dds6qkxpwdeubwucdiaord2xgbbeyds25rbsgr73tbfpqpt4a6vjwsyd.onion stretch main

deb http://deb.whonix.org stretch main
#deb-src http://deb.whonix.org stretch main

Leaving source line disabled by default to safe some time, it’s not useful
anyway, since it’s better to get the source code from git repository.

End of /etc/apt/sources.list.d/whonix.list


#8

This is now solved, I don’t remember how I solved it though!


#9

. https://www.whonix.org/wiki/Dev/git#apt-get_source