The following signatures were invalid : NODATA1 NODATA 2


Today I started Whonix-Gateway and issued an update command but receive the following error:

user@host:~$ sudo apt-get update && sudo apt-get dist-upgrade Hit wheezy Release.gpg Hit wheezy/updates Release.gpg Hit wheezy Release Hit wheezy/updates Release Hit wheezy/main i386 Packages Hit wheezy/updates/main i386 Packages Hit wheezy/updates/contrib i386 Packages Hit wheezy/updates/non-free i386 Packages Hit wheezy Release.gpg Hit wheezy/updates/contrib Translation-en Hit wheezy/updates/main Translation-en Get:1 wheezy Release.gpg [635 B] Hit wheezy Release Hit wheezy/updates/non-free Translation-en Get:2 wheezy/main i386 Packages [5,859 kB] Get:3 wheezy/contrib i386 Packages [42.3 kB] Ign wheezy/main Translation-en_US Ign wheezy/main Translation-en Get:4 wheezy Release [635 B] Ign wheezy Release E: GPG error: wheezy Release: The following signatures were invalid: NODATA 1 NODATA 2

I checked the forum and found (as I thought) a solution here: Whonix Forum
I successfully fetched the key: fpr="916B8D99C38EAF5E8ADC7A2A8D66066A2EEACCDA" gpg --recv-keys "$fpr" gpg --fingerprint "$fpr" gpg --export "$fpr" | sudo apt-key add - and tried faking the time also sudo faketime 2015-01-15 apt-get update sudo apt-get dist-upgrade but got absolutely the same output…

Anyone knows a solution for this issue? Thanks.

BTW, everything worked fine for me couple of months before. I downloaded a new image and here you go…

Now fixed.

Great, it works! Thank you.