[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

TBB and Thunderbird


#1

I have TorBrowser 8.0a6 together with an updated Thunderbird.

It seems impossible to me to get Hyperlinks from TB open up in the TorBrowser when klicking on them - just nothing happens.

I got the browser as my default browser and I do have “janondisttorbrowser” in my SystemSettings on the Workstation.

I can open up links in a parallel installed Firefox with no problem. What should I do?

Thanks


#2

See if execution is blocked by apparmor:

sudo journalctl -k | grep 'apparmor="DENIED"'


#3

Sorry that doesn`t return anything :frowning:


#4

user@host:~$ sudo journalctl -k

– Logs begin at Sat 2018-05-05 15:15:22 UTC, end at Sat 2018-05-05 19:41:34 UTC. –
May 05 18:29:18 host kernel: [sched_delayed] sched: RT throttling activated


#5

sudo dmesg | grep 'apparmor="DENIED"'

Run after clicking a link that you want to open in Tor Browser.


#6

Sorry - that doesn’t return anything as well :frowning:


#7

Check Thunderbird settings:

Menu -> Preferences -> Attachments

Is “Use torbrowser” selected?


#8

it is on “Always ask” because it doesnt keep/take “janondisttorbrowser.desktop”

But even when empty and selecting choose other application “janondisttorbrowser.desktop” when asked it doesnt work…


#9
  • Whonix 13 or 14?

  • How did you install Thunderbird?

  • How did you install Tor Browser?

  • update-alternatives --list x-www-browser
    Is /usr/bin/torbrowser listed?

  • if you type torbrowser from terminal, does it launch Tor Browser?


#10

-Whonix 13
-apt-get install thunderbird
-with TorBrowserDownloader

user@host:~$ update-alternatives --list x-www-browser
/usr/bin/firefox-esr
/usr/bin/torbrowser
/usr/lib/open_link_confirmation
user@host:~$ ls /usr/bin/torbrowser
/usr/bin/torbrowser

-yes it starts Tor Browser


#11

I don’t have the setup to recreate your issue so I’ll take a couple more shots, then let someone else jump in.

janondisttorbrowser.desktop doesn’t work for me either. Isn’t “Use Tor Browser (AnonDist) (default)” one of your choices?

icedove should have been installed by default, then upgraded to thunderbird with a dist-upgrade. Did you install thunderbird separately on your own? Reason I ask is because this 4 year old post says:

Whonix sets those to true by default. Maybe your self-install has different settings although TBH I don’t know why that setting would matter.


#12

Ok, try this:

  1. Leave it on “Always ask” and click a link.
  2. “Choose other Application”
  3. Click on “File System” in left panel and navigate to /usr/bin/torbrowser

#13

Hi entrOpy - the last hint “navigate to /usr/bin/torbrowser” helped - thank you very much for that and your time!!

Those " network.protocol-handler.warn-external" were already set to true by default.

Now the only question left is how to get read of that warning:
“The following link will be opened in Tor Browser.
Be careful if Tor Browser is already running as your activities might get linked.” to speed things up a bit when hitting a hyperlink.


Tor browser in Whonix
#14

Undocumented.


#15

Thank you Patrick for your hint.

Unfortunately setting “link_confirmation_for_links=0” results in not opening the link at all and not in not popping up that warning box :frowning:


#16

That was fixed by

You can manually edit /usr/lib/open_link_confirmation.

Move fi from line 201 to after the fi on line 205.
($answer check should be nested)


#17

I already forgot about that one! :slight_smile:


#18

Thank you both again - that question is solved!