[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

tar: Whonix-Workstation-XFCE-16.0.5.3.Intel_AMD64.qcow2: Cannot write: No space left on device

Hello,

I’ve been trying to install Whonix on my PC running Linux Mint 20.3 (Cinnamon) for some days but haven’t been able to figure out what the problem is. It might have something to do with sparse files but I have no idea how to go about fixing the issue. Can’t find any fixes online.

Basically the problem arises when running the tar command on the archive file. It starts extracting and keeps doing the process until my disk is full and it can’t go on anymore. Each of the .qcow2 files go over a 100gb

The terminal goes as follows.

tar -xvf Whonix*.libvirt.xz
WHONIX_BINARY_LICENSE_AGREEMENT
WHONIX_DISCLAIMER
Whonix-Gateway-XFCE-16.0.5.3.xml
Whonix-Workstation-XFCE-16.0.5.3.xml
Whonix_external_network-16.0.5.3.xml
Whonix_internal_network-16.0.5.3.xml
Whonix-Gateway-XFCE-16.0.5.3.Intel_AMD64.qcow2
Whonix-Workstation-XFCE-16.0.5.3.Intel_AMD64.qcow2
tar: Whonix-Workstation-XFCE-16.0.5.3.Intel_AMD64.qcow2: Cannot write: No space left on device
tar: Exiting with failure status due to previous errors

Thanks for the response in advance!

I don’t maintain Whonix KVM but this one seems simple.

Try have a look text that you posted.

That’s probably it.

But I’ve got over 200gb free space on my SSD. Surely that should be plenty enough. And while the extracting process is going, all of the disk space is slowly disappearing until no space is left.

When I run the du -h command, I shows that the qcow2 file is 101gb
Same thing happens when I run it by checking apparent size. Both ways it’s showing 101gb
But it was over that when I checked the sizes through the GUI properties

Could be an issue with sparse files.

(Whonix is based on Kicksecure.)

Could be that your file system does not support sparse files?

Can probably only be resolved as per https://www.kicksecure.com/wiki/Free_Support_Principle.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]