Systemcheck hangs up on Time Synchronization

I recently updated Gateway and Workstation to 16.0.4 running out of Virtual Box. I had some connectivity issues and had to update usr/local/etc/torrc.d/50_user.conf

Now everything seems to work fine but I still can’t connect to Tor due to a Time Synchronization error. When I run systemcheck I get the following message:

[ERROR] [systemcheck] Time Synchronization Result:
systemcheck gave up waiting.

Time synchronization status: fail
sdwdate reports: Maximum allowed number of failures. Giving up.

Checking the sdwdate logs gives me some more info:

START: ### /usr/libexec/helper-scripts/onion-time-pre-script

__ Status: Subsequent run after boot.
__ Static Time Sanity Check: Within minimum time ‘Fri Feb 18 00:00:00 UTC 2022’ and expiration timestamp ‘Tue May 17 10:00:00 UTC 2033’, ok.
__ Tor circuit: established
__ Tor Consensus Time Sanity Check: Clock within consensus parameters consensus/valid-after 2022-11-28 14:00:00 and consensus/valid-until 2022-11-28 17:00:00.
__ Conclusion: Tor already reports circuit established.
__ ### END: ### Exiting with exit_code ‘0’ indicating ‘success’.
2022-11-28 14:59:21 - sdwdate - INFO - PREPARATION RESULT: SUCCESS.

But when the Onions are pulled in to establish the time, all URLs produce the same error message:

Failed to establish a new connection: [Errno 111] Connection refused

Ultimately ending with the summary:

2022-11-28 14:59:22 - sdwdate - INFO - failed_urls: 9 allowed_failures: 7
2022-11-28 14:59:22 - sdwdate - ERROR - Maximum allowed number of failures. Giving up.
2022-11-28 14:59:22 - sdwdate - INFO - Sleeping for 90 minutes, ok.

I’ve tried restarting sdwdate, restarting network and restarting Tor via Gateway and Workstation. I’ve also tried setting the time/date manually but this didn’t fix anything. Can someone tell me where I’m going wrong?

Manually setting the time cannot fix sdwdate. After you manually set the time you’re all set and done. Then you basically did sdwdate’s job.

Attempts to fix sdwdate:

  1. Check if your local /etc/sdwdate.d/30_default.conf matches sdwdate/30_default.conf at master · Kicksecure/sdwdate · GitHub. If not, then you did not receive all updates. (Sometimes the git version might be ahead of the version shipped in packages but that’s not the case at time of writing.)

  2. Check if you can open the onions where sdwdate failed in Tor Browser. If you cannot, then sdwdate won’t be able to either. Or pick some onions from the sdwdate config and try to open them in Tor Browser.

  3. Your Tor client might have chosen a slow Tor entry guard. → Tor Entry Guards - Whonix chapter Manual Rotation of Tor Guards in Whonix wiki

  4. There could be a network obstacle?

  1. The Tor network might be too slow / under DOS / overload. In that case I won’t be able to suggest a solution. But not likely because we don’t have many similar reports currently.

I was running our /usr/share/sdwdate/onion-tester just now and all sdwdate onion time sources so far were OK.

1 Like