systemcheck: ERROR: check network interfaces Result: network interface eth0 not up! / Anon Connection Wizard Stuck on Starting

Hi there,

I recently updated my QubesOS from 4.1 to 4.2. I then upgraded from Whonix 16 to 17. I think it worked once when the Connection Wizard started automatically. After that, no such luck. When I run the System, it says my eth0 interface isn’t up and that I should restart the networking service. I did that, but it didn’t work. I’ve tried a few guides on the forums but nothing has worked.

Any guidance please?

Post exact error message.

The GUI interface says:

ERROR: check network interfaces Result: network interface eth0 not up!

Try to manually start Whonix networking.

            sudo systemctl restart networking

Or reboot.

Debugging information:
sudo --non-interactive cat /sys/class/net/eth0/carrier

If this error happens only during upgrading or is transient this error can be safely ignored.
If you know what you are doing. feel free to disable this check. Create a file /etc/systemcheck.d/50_user.conf and add:

         systemcheck_skip_functions+=" check_network_interfaces "

Just to add, rebooting and restarting the service didn’t fix the problem. I am also unable to view the content of the carrier file. It says cat: carrier: Invalid argument

Probably some dom0 settings are messed up.

Qubes salt (qubesctl) might be able to fix this. Documented here:
Download and Configure Whonix Templates

Otherwise I recommend to uninstall.

And install.

Anon Connection Wizard (ACW) is unrelated. It is listed as Unsuitable Connectivity Troubleshooting Tools.

I tried the uninstall re-install process two times and the problem remains the same.

Any error during Qubes salt?

Any custom VMs other than sys-whonix and anon-whonix?

At least sys-whonix and anon-whonix should be functional?

When you say Qubes salt, you mean this command?

sudo qubesctl state.sls qvm.anon-whonix

If yes, no errors presented in the entire uninstall and reinstall processes.

No custom VMs using Whonix.

sys-whonix still presents the same errors.

So we need to compare the dom0 settings of sys-whonix in Qubes installation with release upgrade bug versus a Qubes installation without release upgrade bug.

In dom0:

qvm-prefs sys-whonix

In my opinion, release upgrade isn’t worth the trouble anyhow.

What is better? Upgrade or Image Re-Installation? See Update vs Image Re-Installation.

So a clean re-installation might be easier than debugging this to avoid running into lots of corner cases which only very few users are experiencing.

related Qubes upstream issue: