[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Sys-whonix tor control panel bug

Qubes 4.1

When I use ‘custom bridges’ & press accept the setting shown then for bridges is ‘None’.

How to reproduce:
Select Time Synchronisation Monitor in the Qubes system tray, choose in the menu appeared sys-whonix->Tor control panel , on opened ‘Tor control panel’ window choose configure, in ‘Bridges type’ choose ‘Custom bridges’, press ‘Accept’ . Now enter bridges received from tor project, press ‘Accept’. The window shows Tor status connecting to Tor & then Tor is connected, but in user configuration part of the window the ‘Bridges type’ are shown as ‘None’ - this is a bug - please fix.
Also custom bridges are not saved - next time I boot Qubes the ‘Tor control panel’ doesn’t show the custom settings. If this is normal, due to the running VM is app-VM,then please provide detailed instructions how to update template VM with the ‘Custom bridges’ settings so they persist.

//cc @iry @troubadour

I can confirm that there’s a usability bug here.

tor-control-panel (TCP) and anon-connection-wizard (ACW) are tools that write Tor configuration files and restart Tor. Full stop. Really. That’s all that these tools do. And that’s all what can be expected at this time.

To audit what configuration snippets are created by these tools, have a look at this file:

/usr/local/etc/torrc.d/40_tor_control_panel.conf

Tor configuration state inspection, i.e. when re-running these tools and showing the configured state is much harder to implement and not implemented.

Unlikely this will be fixed due to lack of developers. Both TCP and ACW have been contributed in the past but the contributions since went inactive.

User options:

  • A) ignore tor-control-panel (TCP)
  • B) use anon-connection-wizard (ACW) instead
  • C) ignore both TCP and ACW, go straight to use Manual Bridge Configuration instead.

Realistic Whonix development options:

  • A) replace TCP menu entry in sdwdate-gui with ACW
  • B) remove TCP menu entry in sdwdate-gui
  • C) entirely remove TCP from Whonix default installation
1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]