[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Spice will not give a graphical display of Whonix, but VNC will.


#1

Been trying to set up Whonix with KVM, but hit a bug that I was not able to resolve with searching the error. When starting either Whonix-Gateway or Whonix-Workstation with default XML and KVM (with graphical virt-manager) it gives the error:

[quote]Cannot display graphical console type ‘spice’:
No module named SpiceClientGtk[/quote]

After some searching this error I have tried installing spice-client (with apt-get install spice-client) and it turned out it was indeed not installed during the KVM install (should it?). However this did not resolve this error.

After that I tried using another virtualization platform, VNC, by changing the Display type from Spice to VNC under “Show virtual hardware details”. This worked, Whonix with VNC gives a correct graphical display.

How could I resolve the Spice error? Or is using VNC instead of Spice a viable alternative and what security consequences will it have? Are those easy to migrate?


#2

Sounds like broken dependencies.

Try reinstalling the KVM packages to see if its resolved:

sudo apt-get install (kvm package names from wiki here)

VNC is NOT a viable alternative. It is neither secure nor performant.