[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Something Went Wrong!


#1

Whonix-Qubes , tester repository.

i open the TBB 5.5.1 as usual , then a new tab opened saying this message:-

???


#2

Good day,

this applies here as well: https://www.whonix.org/wiki/FAQ#check.torproject.org_says_.22Sorry._You_are_not_using_Tor..22

Have a nice day,

Ego


#3

thought that as well , but the funny thing is:-

i went to torcheck link while that error appeared = it says im using Tor ???

so i got lost. but the real question that we should ask: is that because of Tor/TBB or because of Whonix ? and good answer to this question no body know atm, nor it will be easy.

but i reported this issue , in case if anyone got it at the same time then the problem going to be identifiable easier if its from here or there.


#4

Good day,

did you access torcheck via the same window or tab? Because otherwise streamisolation has given you a new exit node which got detected.

Have a nice day,

Ego


Something Went Wrong! Tor is not working in this browser.
#5

How did you end up on about:tor? By manually entering that page? Using Tor Browser 6.0a1-hardened on Qubes-Whonix and a new tab does not result in this for me.

check.torproject.org is not the same as about:tor. This is Tor Browser’s own Control Port verification test. How that test works is briefly described on the following page:

This test is not useful in Whonix at all. It’s not even a false positive. It’s just an obscure condition that leads to a test failing that would not be useful in Whonix anyhow.

The following page also applies:


#6

yeah the same window , thats why it was funny. (how , what the…etc)

like i said i opened the TBB like any normal person would do , and a new tab window jumped up witha image above.

By manually entering that page?

manually entering that page ? what do u mean :open_mouth:?

Using Tor Browser 6.0a1-hardened on Qubes-Whonix and a new tab does not result in this for me.

that message appeared while im using TBB 5.5.1.

This test is not useful in Whonix at all. It’s not even a false
positive. It’s just an obscure condition that leads to a test failing
that would not be useful in Whonix anyhow.

oh i c.

hope nothing harmful inside my WS.


#7

“By manually entering that page?” I meant, did you open the Tor Browser, clicked into the domain bar, typed about:tor and pressed enter.


#8

nope , it just popped up when i opened the TBB.


#9

Does it persist? When it stopped? Does it still happen?


#10

Does it persist?

in that time => nope

When it stopped?

when i have restarted the WS

Does it still happen?

from that time , it didnt happen with me.


#11

Coincidentally, this just happened to me today as well.

Restarting Tor Browser didn’t fix but restarting VM did.

Not sure why it happened since TOR_SKIP_CONTROLPORTTEST=1 was set.

Maybe it’s a sign I should: https://www.whonix.org/wiki/Advanced_Security_Guide#Disable_Control_Port_Filter_Proxy

I’d like to leave it enabled in the Gateway. Can I just delete the rinetd redirection?


#12

interesting , hmm and we cant even know how to produce it