[SOLVED with recent update] Rebuilding webserver in Whonix 17 - can't connect to onionservice

In the process of upgrading to Qubes 4.2-rc4 from 4.1. Had web services running as onion services using Whonix. Could not update them in place because of usrmerge problems with Qubes storing important files in /lib/modules. So I am trying to rebuild from copies of the new Whonix 17 templates.

Anyway, I cannot seem to get my web server available as an onion service. I just double checked the docs here:

And I think I covered all that.

I can access the webserver from browser in that Qube VM via

I can access the internet in a browser in the server Qube VM

But I cannot access the website i’m trying to serve via the onion address (from another qube). I can access other websites from this same qube/tor browser.

I set up the whonix firewall on the workstation/server, and set its IP address in the settings in /usr/local/etc/torrc.d/50_user.conf on the gateway. Those are the 2 things that I’ve missed in the past.

Any ideas for testing the connection problem?

Webserver also needs to listen not only on

1 Like

OK, can you say more about how to do that?

I can also access it at the local ip 10.137.0.xx

And I set up




and ran


with no errors

Try setup a “normal” onion service in a reinstalled Whonix exactly as per documentation first before you try any special customized setups.

Yeah, I am starting from scratch with a fresh Whonix 17, since upgrading my old one didn’t work.

Other than some nginx/php.ini settings, I haven’t done anything besides the basic setup in the docs. And I didn’t do authentication or load balancing or anything.

I basically:

  1. installed nginx/php/mariadb
  2. changed some nginx.conf/php.ini settings
  3. set up tor config on gateway to go to IP address of server
  4. opened the firewall part on the whonix workstation

UPDATE: It’s working.

I just updated whonix-gateway-17, which included some qubes component updates. Rebooted the server and the gateway. And now i can connect via tor Browser.

I guess these were new updates as I’m fairly certain I updated the templates as soon as I installed them (and there were a lot more updates than this morning).

Thanks for the support while i got it working.