[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

[Solved] Whonix14/Qubes3.2 latest upgrade prevent tor browser from launching


#1

Related, but separate issue: [Solved] Whonix14/Qubes3.2 latest upgrades block apt networking

In Whonix workstation based on upgraded Whonix 14 template, tor browser will not launch. Instead there is a pop-up explaining that there is Error: 139. I can provide a screenshot if needed.

Thanks for your time.


#2

Screenshot not necessary but ok. Textual copy/paste would suffice.

Please start Tor Browser from command line also.

As well as please start Tor Browser from command line with debugging as well.

Instructions can be found here:

https://www.whonix.org/wiki/Tor_Browser#From_the_Command_Line_or_Debugging_Mode


#3
user@host:~$ torbrowser
[ERROR] [torbrowser] Failed to start Tor Browser!

Failed to run:
/home/user/.tb/tor-browser/Browser/start-tor-browser --allow-remote "file:///usr/share/homepage/whonix-welcome-page/whonix.html".

Exited with code: 139

To see this for yourself, you could try: Start Menu -> Applications -> System -> Terminal
Then run:
torbrowser
user@host:~$ cd .tb/tor-browser/Browser/
user@host:~/.tb/tor-browser/Browser$ ./start-tor-browser --debug
./start-tor-browser: line 370:  2184 Segmentation fault      TOR_CONTROL_PASSWD=${TOR_CONTROL_PASSWD} ./firefox --class "Tor Browser" -profile TorBrowser/Data/Browser/profile.default "${@}" < /dev/null

#4

@Patrick Just mentioning you in case you missed my reply here. :slight_smile:


#5

Didn’t miss. Just have no idea.


#6

Some more strange things. In my Whonix workstation AppVM based on a template which was not upgraded, I can start tbb with /usr/bin/torbrowser, however I get the same error as above when I try to manually execute ~/.tb/tor-browser/Browser/start-tor-browser.

Some logs:


#7

Please ask Tor Project about https://paste.debian.net/plainh/9170feda.

https://lists.torproject.org/pipermail/tbb-dev/


#8

https://lists.torproject.org/pipermail/tbb-dev/2018-June/000860.html


#9

It was suggested on the list that my problem could be this issue: https://trac.torproject.org/projects/tor/ticket/25305. Looks like a good possibility.


#10

Output of …?

env | grep XDG_CONFIG_DIRS

#11

XDG_CONFIG_DIRS=/usr/share/torbrowser-default-browser/:/usr/share/security-misc/:/usr/share/kde-apper-no-autoupdate/:/usr/share/anon-ws-kde-startmenu/:/usr/share/anon-apps-config/:/usr/share/open-link-confirmation/:/etc/xdg

Looks like torbrowser had a function to workaround this issue which was removed with this commit.

Edit: I can confirm that adding the workaround function back in to the current torbrowser launches successfully for me.


#12

But at the same time the number of XDG_CONFIG_DIRS entries was reduced.

Mine:

XDG_CONFIG_DIRS=/usr/share/torbrowser-default-browser/:/usr/share/security-misc/:/usr/share/anon-ws-kde-startmenu/:/usr/share/anon-apps-config/:/usr/share/open-link-confirmation/:/etc/xdg

Did you forget to run sudo apt-get autoremove?


#13

Apt reports nothing to remove.

/usr/share/kde-apper-no-autoupdate is the only entry I have that’s not in yours. Which doesn’t even exist in /usr/share.

user@host:~$ ls /usr/share/ | grep kde
anon-ws-kde-startmenu
kde4
user@host:~$ sudo find / | grep kde-apper-no-autoupdate
/etc/X11/Xsession.d/50kde-apper-no-autoupdate
find: ‘/proc/20811/task/20811/net’: Invalid argument
find: ‘/proc/20811/net’: Invalid argument
user@host:~$ cat /etc/X11/Xsession.d/50kde-apper-no-autoupdate 
## Copyright (C) 2012 - 2018 ENCRYPTED SUPPORT LP <adrelanos@riseup.net>
## See the file COPYING for copying conditions.

if [ -z "$XDG_CONFIG_DIRS" ]; then
   XDG_CONFIG_DIRS=/etc/xdg
fi
export XDG_CONFIG_DIRS=/usr/share/kde-apper-no-autoupdate/:$XDG_CONFIG_DIRS

#14
dpkg -l | grep kde-apper-no-autoupdate

?

sudo apt-get purge kde-apper-no-autoupdate

?

sudo rm /etc/X11/Xsession.d/50kde-apper-no-autoupdate

Then reboot. Fixed?


#15

The package kde-apper-no-autoupdate did not exist, but somehow the file remained. After rm’ing the file the situation is solved.

Thank you, once again, for your awesome support. I have so much respect for the development teams both here and at Qubes.