[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

[Solved]Vbox error in starting Whonix Gateway

Hello. I try to import whonix-gateway by setting 130MB RAM, it is successful but when I start the Gateway by clicking green arrow button above, it says

Failed to open a session for the virtual machine Mint. The virtual machine 'Mint' has terminated unexpectedly during startup with exit$ Result Code: NS_ERROR_FAILURE (0x80004005) Component: Machine Interface: IMachine {5eaa9319-62fc-4b0a-843c-0cb1940f8a91}

Also, in another error box says kernel module missing and to install it, I must run “/etc/init.d/vboxdrv setup”

I run that command under terminal with sudo from admin account of my Mint, but it says command not found.
Is it because I use OSE instead of non-free proprietary? :frowning:

Thanks.

Also, in another error box says kernel module missing and to install it, I must run "/etc/init.d/vboxdrv setup"
Maybe you have to reboot after installing virtualbox.

Looks like something went wrong installing VirtualBox. Most likely also other VMs, non-Whonix VMs won’t work for you as well? In that case, not a issue introduced by Whonix. Most likely a mint/VirtualBox related problem.

Please post the output of.

sudo apt-get update sudo apt-get purge virtualbox* sudo apt-get install virtualbox linux-headers-$(uname -r)

Likely you also didn’t have kernel headers installed. No idea why the virtualbox package doesn’t depend on kernel headers.

Whonix doesn’t require any non-ose features. In other words it doesn’t require the non-ose extension pack. For sure.

Let’s look at the Debian packages, which are apparently mirrored by mint.

The main package is:
https://packages.debian.org/wheezy/virtualbox

The -ose package (https://packages.debian.org/wheezy/virtualbox-ose) is deprecated. Not because there is no ose version anymore, just because the non-ose stuff can be downloaded from virtualbox.org and is called “Oracle VM VirtualBox Extension Pack” - no longer in the main package.

Looking at the “Oracle VM VirtualBox Extension Pack” documentation (https://www.virtualbox.org/manual/ch01.html#intro-installing)…

Additional extension packs can be downloaded which extend the functionality of the VirtualBox base package. Currently, Oracle provides the one extension pack, which can be found at http://www.virtualbox.org and provides the following added functionality:
The virtual USB 2.0 (EHCI) device; see Section 3.10.1, “USB settings”.

VirtualBox Remote Desktop Protocol (VRDP) support; see Section 7.1, “Remote display (VRDP support)”.

Host webcam passthrough; see chapter Section 9.7.1, “Using a host webcam in the guest”.

Intel PXE boot ROM.

Experimental support for PCI passthrough on Linux hosts; see Section 9.6, “PCI passthrough”.</blockquote>

These are additional features. None of this is required to start a VM.

There is currently another issue with VirtualBox free/non-free, but it will be a problem in Debian jessie (testing at time of writing) based host operating systems. This issue seems to be unrelated from this one and you can read a bit more about it here:

Installing Linux-headers and restarting fixed the problem.
Thank you for the detailed reply.
I fear proprietary stuff, that’s why I was bit scared in the previous post the question about non-free Virtualbox.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]