[SOLVED] Using an alternative OS (Android) (DHCP)


I want to use Android-X86 with Whonix Gateway. I have followed the website:

and wanted to add the static configuration of eth0 as follows:

ifconfig eth0 netmask

route add default gw dev eth0

setprop net.eth0.dns1

Those comments seam to be accepted by Android-X86, but unfortunately it does not really work.

When I try to download any file with wget it says “no route to host”.

Any suggestions on how to configure Android in a VM to use the Whonix Gateway?

Edit by Patrick:
Added “(DHCP)” to the title.

Android uses a stripped down version of Linux that lacks native virtualization options like KVM. The company Oracle, the one behind VirtualBox has no plans to support Android x86 or any other hardware architecture. Thats why you are out of luck when trying to host Whonix on Android.

I think he wants to use Android in a VM, not as a host.

Can you provide a link to the operating system you want to use in a VM please?


Thanks for taking your times to answer to my topic. I have been using the following image:

Now I saw that it says “Support Ethernet (DHCP only)”. After installing a dhcp-server on the Whonix Gateway it actually works!

I have installed a dhcp server on the Gateway in this way:

  • sudo apt-get install isc-dhcp-server
  • sudo dpkg-reconfigure isc-dhcp-server
  • Then choose eth1 as the interface to run the DHCP server on.
  • sudo nano /etc/dhcp/dhcpd.conf
  • change the config-file to only consist of the following:
option domain-name "whonix";
# Use its own DNS server:
option domain-name-servers;
# Set up our desired subnet:
subnet netmask {
    option subnet-mask;
    option broadcast-address;
    option routers;
default-lease-time 600;
max-lease-time 7200;

Now android-x86 can automatically establish a connection through whonix.

Do you think this configuration of my dhcp server is safe? I would make a snapshot and only use the snapshot containing the dhcp server when I need to run the android-vm.

I moved the discussion about DHCP server in gateway to here:

My quick 2 cents, alyserm, is that you’re fine – although I would like to get to the bottom of why manual configuration didn’t work (it should have worked without much fuss).

Bump, this mini-HOWTO is obsolete now that Whonix 9 changed network settings.

Shouldn’t Android have its own section in /wiki/Other_Operating_Systems and this snippet go there, adjusted to work for Whonix 9?

Please feel free to hit the edit button and add it.


PS: the footer of /etc/network/interfaces still contains deprecated network settings now that Whonix 9 is released. Albeit commented, those could be super useful in providing insights about correct values for network/subnet and broadcast. I suggest modifying those things to make them helpful.

Thanks. Link:
Anonymize Other Operating Systems

Added a warning related to DHCP.

1 Like