SOLVED: Set up SSH into Workstation - Socket error

Using a headless setup, I am trying to SSH into the Workstation (SSH > Host > SSH > Gateway > SSH > Workstation - per https://www.whonix.org/wiki/File_Transfer#SSH_into_Whonix-Gateway).

The connection from Host to Gateway has been successfully created. Now trying to set up the connection from the Gateway to the Workstation. I am stumped as to why I am getting the following error:

user@host:~$ /usr/bin/ssh.anondist-orig user@
Read from socket failed: Connection reset by peer

I have tried researching, but am unable to find any useful direction.

Can anyone assist?

EDIT: Figured out the issue. I had to rebuild the ssh keys on the workstation and reinstall openssh server/client.

did you just replace ssh keys with ssh-keygen -t ed25519 ? or something else?

i am in a similar position and after reading the instructions again and again, i am stumped.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]