[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

[Solved] ro-mode-init not working

So I finally bothered to move from 14 to 15 and having a couple teething troubles.

I did the fresh image install rather than upgrading the 14 to 15.

First thing I notice is that both gateway and workstation take an age to shutdown now (like 2minutes). I tried changing from 512 ram to 1gig and made no difference so wondering if it might be something else?

Secondly the ro-mode-init doesn’t seem to work for me. I installed the package and shutdown and set kvm to read-only and reboot and check the live mode in startup however it seems to just boot into the grub one rather than ro-mode one because the tick is in the system tray and from reading the wiki that only happens in the grub version and more importantly whenever I reboot it does not autoboot into live-mode which is the main thing I want.

So what could be going wrong here in both these cases?

i have not gotten ro-mode-init to work for autobooting into live mode yet either. an easy work around for the moment is to edit “/etc/default/grub” and change “GRUB_DEFAULT=0” to “GRUB_DEFAULT=2”. then, run “sudo update-grub”. on your next boot, the live mode will be selected by default going forward. it’s a simple minor failsafe for a situation where you may have inadvertently forgotten to set your whonix disk back to “readonly” in virt-manager.

Inefficient to discuss multiple issues in 1 forum thread. Please create a separate forum thread for that one.

This description is too inaccurate. Can only guess what you mean.

https://www.whonix.org/wiki/Reporting_Bugs#Reporting_Guidelines

You’re expecting the the grub boot menu

grub boot screenshot:
https://www.whonix.org/w/images/c/c5/Persistent_boot.png

To switch to Live mode automatically?

Since grub-live is installed by default now I guess this causes confusion to co-install ro-mode-init. The second grub boot menu entry should not be there.

This might be fixed in git master. Whonix live mode / amnesia / amnesic / non-persistent / anti-forensics
Untested.

ro-mode-init does not yet automatically run:

 sudo update-initramfs -u

This might be fixed in git master. Whonix live mode / amnesia / amnesic / non-persistent / anti-forensics
Untested.

No, but I was expecting the system to boot into live-mode automatically. I had no idea it was due to a conflict with boot loaders as I had no idea the ro-mode package was also a boot loader; I thought maybe it just changed some settings in the current one in order to do its thing.

I don’t think I can be blamed for that when I followed the wiki to the letter, or so I thought ,and it said nothing about this. Not criticising but I had know way to know.

The wiki just says once the ro-mode package is installed to set your hard-drive to read-only, which I did, and reboot and select Live-Mode from the menu in order for it to automatically boot into read only mode on each boot.

sudo update-initramfs -u

This part is missing from the wiki.

It makes more sense given what you say about them being both boot-loaders in conflict with one another.

Also part of my confusion was that I don’t remember such issues when I installed 14, I think it automatically switched switched to the ro-mode one once it was rebooted.

Will try with suggestions mentioned, thanks.

EDIT:

sudo update-initramfs -u

seems to have fixed the issue. I will make a new one about the slow shutdown problem.

wiki updated just now:

https://www.whonix.org/w/index.php?title=Whonix_Live%2Fro-mode-init&type=revision&diff=54268&oldid=53245

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]