[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

[solved]AirVPN not working with whonix?

Hi!
I have written to AirVPN support about being stucked when trying to connect to one of their many servers and they think that the problem could be something related to whonix… So my question is:
Does whonix even support services like airvpn?

Thanks!

Good day,

By design, Whonix doesn’t restrict any kind of VPN. OpenVPN based ones usually work as explained here: https://www.whonix.org/wiki/Tunnels/Connecting_to_Tor_before_a_VPN

It would be great if you could get into more detail what you did and where your problem lies.

Have a nice day,

Ego

1 Like

Yeah, the support replied:
Hello!

WHONIX uses Tor in the gateway machine and Tor does not (and can not) support UDP. Try to switch to TCP. You can change connection mode in “AirVPN” > “Preferences” > “Protocols”.

Kind regardsm
AirVPN Support Team

However I tried to switch to TCP with port 443 and it still says “connection refused”. Does it support TCP with port 443? I can also selct TCP with port 80 etc.

Thanks!

Every VPN provider has their own specific arbitrary port settings. You have to ask them.

You are correct. Thanks

Not clear if

  • User -> proxy/VPN/SSH -> Tor -> Internet OR
  • User -> Tor -> proxy/VPN/SSH -> Internet

Please state which one it is. See also:

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]