Snowflake proxy option in Tor control panel not working

I can’t use snowflake proxy. It gets stuck at 0%. “Show sdwdate status” gets stuck at “initial time fetching in progress” and nothing happens past that.

I tried the solution posted by @tzwcfq in this thread I found even though it’s not exactly the same issue, but it didn’t improve things: (well apparently I can’t post links here, but it’s a thread labeled “Snowflake proxy causes crash in tor-control-panel” in the qubes forum)

Does snowflake work for anybody here on qubes-whonix?

Does Configure (Private) (Obfuscated) Tor Bridges chapter Snowflake in Whonix wiki help?

I followed the guide and now it gets stuck at 10% instead of 0%. Definite improvement but it still doesn’t work…

I think it’s ignoring my custom configuration. When I go in the control panel logs tab and check torrc, it lists what looks like the default config, not the one I copypasted from the guide. The 50_user.conf file didn’t even exist to begin with. They might have put it elsewhere in qubes-whonix…

This is what the tor log looks like now:

Mar 24 04:00… [notice] Managed proxy “/usr/bin/snowflake-client”: offer created
Mar 24 04:00… [notice] Managed proxy “/usr/bin/snowflake-client”: broker failure dial tcp: lookup ajax(dot)aspnetcdn(dot)com on [scrubbed]: dial udp [scrubbed]: connect: cannot assign requested address
Mar 24 04:00… [notice] New control connection opened.
Mar 24 04:00… [notice] New control connection opened.
Mar 24 04:00… [notice] New control connection opened.
Mar 24 04:00… [notice] New control connection opened.
Mar 24 04:00… [notice] New control connection opened.

It just loops that, while being stuck at 10%. Any clues?

  • in Whonix-Gateway: /usr/local/etc/torrc.d/40_tor_control_panel.conf,


Empty by default by design. Just paste any settings there that you intent to add.

Ignore Tor Control Panel (TCP) and Anon Connection Wizard (ACW) until usability is improved, if ever.

No. To prove it:

Tor Documentation for Whonix ™ Users chapter Edit Tor Configuration in Whonix wiki + add something invalid such as adding keyword “invalid”, restart Tor and it will be broken.


Thank you so much!! I think I got it to work now. I ended up replacing the 40_tor_control_panel.conf with the code from the guide. I had to add DisableNetwork 0 at the top of it because the control panel complained.

After I did that it finally connected to Tor, however I can no longer access the control panel at all. Sdwdate status is success and I can connect to onion sites just fine, but I just can’t launch the panel.

Is there some other way for me to confirm I am actually using snowflake proxy properly? That’s all I’m worried about at this point; I can live without the control panel

EDIT: Never mind, I found a live log (using Nyx) that keeps spouting snowflake-related messages. Pretty sure it’s working. Thank you so much again @Patrick !