[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

share folder and clipboard sharing on debian and fedora hosts


#1

share folder works good on latest stable debian host , i dont test clipboard sharing there.
share folder can’t work on fedora 21 host because of selinux even with privileges.
clipboard sharing works on fedora 21 after i was edit the specific file for that and after quit klipper on guests , disable it for autostart install clipit and enable it for autostart, also i try several clipboard managers on host but resolve it with clipman , (xfce on host),
clipit is lightweiht clipboard manager ,


#2

Nothing to test. its disabled for security reasons.

SELinux messes up shared folders in ways the libvirt hypervisors weren’t able to understand. Stick to Debian if it works for you.


#3

thanks for confirmation HulaHoop , i use at the moment fedora 21 host with usb 3 for transfer files , works perfect , but if you can enable shared folder for fedora host that will be a good idea , because kvm is more stable with fedora from debian , and again : if that is posible . * we know that fedora is the second secusest host for whonix.


#5

shared folder kvm whonix 11 works with fedora 21 host. The workaround :
install policycoreutils-gui , run it and set enforcing mode to permissive from enforcing , install users and groups , run it and go: users/your username/properties/groups/check the root and ok, then go: groups/your username/properties/group users/check the root and ok, then if not allready done the directions for sharing folder kvm on whonix documentation, do that , then evry time when boot in whonix guests must mount the folder if you want to use it, if set fstab for automount automaticaly , in guest booting will stop the booting and show a message by apparmor , you can pass that but guest will boot in emergency mode? i dont know if that is security risk so better don’t edit fstab for automount the shared folder , except if you know that is not a security risk.
If thing that disable selinux is security risk , that is a way for sharing folder, if use usb for transfer files from guest that is again discuraged by whonix maintainers for security reasons, i dont know if take place for security ’ that the usb drive\flash will luks encrypted


#6

clipit cause freezings to virt-manager to , like other clipboard managers, at the end solved with parcellite clipboard manager on guests and host , any other clipboard managers must kill and disable for autostart , also host display manager is responsible for virt-manager freezings , that solved with lxdm ,

  • posts on that topic by me are for : fedora 21 i686 pae with xfce4 host , and for whonix ver. 11.