[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Setting up Java on Whonix

Hey,
I tried to get Java running on Whonix the whole day, but I don’t seem to be able to do it.
I tried getting it to work in TorBrowser aswell as in Iceweasel:

  • I installed Java via: apt-get install openjdk-7-jre-headless

  • I checked TorButton to disable it blocking Java, also checked NoScript which had Java enabled by default

  • I tried putting a symbolic link into the plugins directory of iceweasel, which i had to create first. I used something like that (adjusted ofc): ln -sf /opt/java/jre1.7.0_05/lib/i386/libnpjp2.so /usr/lib/mozilla/plugins/

  • I tried some other stuff I don’t even remember everything

  • In between I cloned the Workstation and Gateway a few times and I still got the images on my harddrive so I’d be able to start from scratch after each fuckup.

If someone knows how to setup a browser with working java applets (thats the goal) inside whomix, pls let me know.
good night :slight_smile:

1 Like

Related documentation generally:

Related documentation specifically:

Note that Tor Browser developers added a patch [10], which blocks all plugins except flash.

Yes I’ve read all that, but thats all theory. I’m aware that the TorBrowser blocks all plugins except flash.

I tried installing the Java Plugin to Iceweasel following a guide on how to install the Java Plugin on Firefox in Linux Environments but I seem to do something wrong.
I’m sorry to bother you with this since it’s not strictly Whonix related, it’s rather a problem with my understanding of Linux.

I’ll try to install Chromium and get the plugin running today. I’ll give an update how it went.

Okay, I started a fresh clone of my gateway and workstation and installed the plugin icedtea into my iceweasel. Iceweasel displayed the installed plugin in its plugin-menu.
After that I checked the website: https://www.java.com/en/download/installed.jsp and I got one step further than yesterday.

Instead of telling me that java isn’t installed or blocked it now shows the frame in which my java version would be displayed normally. It doesnt do that though, all I can see is a grey block.

My browser seems to recognize that java is installed but it doenst work properly, is there anything that might block its use? some firewall setting or something in the iceweasel browser?

Not that I know.

But, I recommend learning how to do this using Debian first. Then replicate it on Whonix. This gives you access to a much bigger support community. As per:

I tried to get Java running in a debian vm, it worked in there. I reached the end of my understanding :frowning:

Tried any other java tests / applets? Perhaps they are just banning Tor users?

You see the plugin under iceweasel -> addons -> plugins?

Yes i can see the plugin in the addons menu.
I tried the Java test apllet and one other. Both the same problem. I get to accept something and the box in which the applet would be displayed turns grey, no error or something.
I’m gonna be at home over the weekend. Happy easter Patrick, thanks for the help so far :slight_smile:

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]