[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

"Setting up anon-base-files" shows machine-id prompt "Configuration file '/etc/machine-id' "install the package maintainer's version"?

Setting up anon-base-files (3:4.4-1) ...

Configuration file '/etc/machine-id'
 ==> File on system created by you or by a script.
 ==> File also in package provided by package maintainer.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      Z     : start a shell to examine the situation
 The default action is to keep your current version.

Doing an update today, and first it asked what language to use, I choose US english. Then a bit later it asked about what to do about /etc/machine-id . Choices included ‘keep existing’ and ‘use the one provided in the package’ ( wording may have been slightly different ). It let me see the existing machine-id and it was different than the packaged one.
Q: Was this an expected question to be seen during an update ? If so, how is a user supposed to know the safe response?
Thankyou.

Install.

Related: Anonymize /etc/machine-id


5. Changed Configuration Files

You can see it’s Whonix with
apt show anon-base-files

1 Like

At this question I went with N of course and it worked after a reboot.
So how to change this to Y after updating? No new updates are found…
Please dont tell me, I have to reinstall Whonix…

sudo rm /etc/machine-id

sudo apt-get install --reinstall -o Dpkg::Options::="--force-confmiss" anon-base-files

Thank you very much! It works! :slight_smile:

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]