[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Sdwdate not changing time?

So I know sdwdate is set in UTC. My host clock is also utc. However it seems that the WS and GW and host all have identical time. Isn’t there supposed to be a slight difference? I remember previous whonix versions had at least 30 min difference or something…

Good day,

First of all, a difference of 30min or more doesn’t sound right, as such a massive difference between every Whonix-User would make each of them more trackable, not less, which is why your previous experience may either be missremembered or based on some other (unknown?) issue.

Secondly, and because of this, your clock is only “set randomly between 5 and 180 seconds into the past or future”, as you may read here: https://www.whonix.org/wiki/Dev/TimeSync#Facts

Have a nice day,

Ego

1 Like

hologone:

So I know sdwdate is set in UTC.

To be exact: Whonix Debian settings are set to UTC. sdwdate itself
does not mind about local clock settings.

My host clock is also utc.

That we have never recommended.

However it seems that the WS and GW and host all have identical
time. Isn’t there supposed to be a slight difference?

The difference is by coincidence / sdwdate inaccuracy. Not by
comparing with the host. So in theory the difference could be 0 but
that is unlikely. And the difference should also change when you
reboot Whonix.

Difference should be seconds.

In Qubes there is a convenient way to see sys-whonix vs dom0 difference.

 qvm-run --pass-io sys-whonix date && date

Are you sure clock is equal up to the second?

I remember previous whonix versions had at least 30 min difference
or something…

No.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]