[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Removing Hexchat plugins per TorifyHOWTO/XChat instructions

Hello. I have been trying to configure Hexchat according to the Privacy Settings section found on:

https://trac.torproject.org/projects/tor/wiki/doc/TorifyHOWTO/XChat

Plugins and Scripts

XChat comes with some modules by default. You can see them under XChat -> Window -> Plugins and Scripts. The ​attack surface can be decreased if you disable those plugins (in case you do not urgently need them). To disable automatic loading of plugins, move them out of the plugin directories. E.g. on Linux:

mkdir /usr/lib/xchat/plugins.disabled/
#to keep python for SASL use this: mv /usr/lib/xchat/plugins/{python.*,tcl.*} /usr/lib/xchat/plugins.disabled/
mv /usr/lib/xchat/plugins/* /usr/lib/xchat/plugins.disabled/

The problem starts with the stated directory not existing in Whonix-Workstation, but that’s fine and makes sense because its referring to Xchat, and we are obviously using Hexchat. I can reach Hexchat’s plugins via Window–> Plugins and Scripts, and can remove them one by one. However, if I shutdown Hexchat and/or reboot the Workstation, they regenerate.

  1. Are these recommendations applicable to Whonix-Workstation?

  2. If so, how do I remove them permanently? I believe I read that I should leave the Python plugin for SASL, which is fine.

You could try deleting or moving them away from:

/usr/lib/x86_64-linux-gnu/hexchat/plugins/

carree:

I can reach Hexchat’s plugins via Window–> Plugins and Scripts, and can remove them one by one. However, if I shutdown Hexchat and/or reboot the Workstation, they regenerate.

Please check for bug upstream.

This has been resolved. Once moving the plugins found in /usr/lib/x86_64-linux-gnu/hexchat/plugins to a new folder, they no longer populate. Thank you Patrick.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]