[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Remmina RDP client broken it seems. Need help ASAP please.

So when I try to use the command: sudo upgrade-nonroot
It does this:

  1. user@host:~$ sudo upgrade-nonroot

  2. [sudo] password for user:

  3. Hit:1 tor+https : //deb(dot)debian(dot)org/debian-security buster/updates InRelease

  4. Get:2 http : //ppa(dot)launchpad(dot)net/remmina-ppa-team/remmina-next/ubuntu hirsute InRelease [18.1 kB]

  5. Hit:3 tor+https : //deb(dot)debian(dot)org/debian buster-updates InRelease

  6. Hit:4 tor+https : //deb(dot)debian(dot)org/debian buster InRelease

  7. Err:2 http : // ppa(dot)launchpad(dot)net/remmina-ppa-team/remmina-next/ubuntu hirsute InRelease

  8. The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 8A993C252155F0BA

  9. Hit:5 tor+https : // deb(dot)whonix(dot)org buster InRelease

  10. Reading package lists…

  11. W: GPG error: http : //ppa(dot)launchpad(dot)net/remmina-ppa-team/remmina-next/ubuntu hirsute InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 8A993C252155F0BA

  12. E: The repository ‘http : //ppa(dot)launchpad(dot)net/remmina-ppa-team/remmina-next/ubuntu hirsute InRelease’ is not signed.

When I try to connect to an RDP it will not connect. I have tried reinstalling whonix, removing and reinstalling remmina. Does anyone know what this problem is or what I should do?

Thanks for any help!

First, get rid of that ppa.
Enable buster backports repository if you didn’t already, so you will get the last remmina release

sudo apt-get-update-plus dist-upgrade
sudo apt -t buster-backports install remmina

sorry for the stupid question but do you know how to get rid of that ppa?

so i think i removed that ppa, i am not sure how to anable buster-backports though.
can you help?

sudo nano /etc/apt/sources.list.d/debian.list

add this line:
deb tor+http://vwakviie2ienjx6t.onion/debian buster-backports main contrib non-free

ctrl+x to save

sudo apt-get update
sudo apt -t buster-backports install remmina

I really appreciate the help!! I know im probably bugging you with the questions, but when I get to installing remmina with buster-backports (sudo apt -t buster-backports install remmina) it gives me the error:
E: The value ‘buster-backports’ is invalid for APT::Default-Release as such a release is not available in the sources
I did add what you said in the sources list.

https://www.whonix.org/wiki/Install_Software#Backports

Thank you! I am going to do that.

https://pastebin(dot)com/f49KGhs5
I did what that instruction manual said, no errors. Still though when I run remmina by just double clicking the icon it doesn’t connect to my RDP. It says “cannot connect to the RDP server.” I would think that this could be some sort of error on the RDP end, but the fact that I started having issues with remmina when I ran sudo upgrade-nonroot at the same time remmina stopped connecting to my RDP, I feel like the problem is still with me. I’m on a fresh whonix VM, the only thing I have installed is Remmina and the only thing I’ve tampered with is what that guide said. Could there be anything I could try tampering with in remmina?
This may be a stupid question but I just got a new router, could that have anything to do with this issue?

The pastebin link is what happens in the terminal when I run remmina as sudo, then try to connect to my RDP.

By the way all of my Remmina settings are default when I connect to the RDP.

Try this first:

Very unlikely.

Try whonixcheck.

If that works, if Tor is already functional, very unlikely the router can mess up that specifically.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]