[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Recommended Specs

I’ve been having trouble with whonix workstation freezing and becoming unresponsive to the point i have to hard reset my laptop.

I have a XPS 15 I bought last year with an i5 8th generation and 8GB of RAM on a solid state drive and onboard GPU.

After much frustration I reinstalled whonix completely. My laptop OS is Manjaro Linux.

I’ve tried setting the Gateway to 192MB RAM as a GUI seems pointless for my use and the cores to 2 and video memory to 16MB.

The workstation is set to 4096MB RAM with 3 cores and 128MB video memory.

I can’t seem find a proper setting that doesn’t cause hard lockups. And as I mentioned this is fresh out of the box setup with nothing changed.

Any suggestions for settings based on my hardware?

Also side note: Full screen mode quit working on the old instances out of the blue and isn’t working on the new either.

Do you use KVM or VirtualBox?
On KVM increasing CPU cores may cause the VM to slow down/freeze:

Have you tried with the default settings?

1 Like

I’m using Virtualbox. Is there any reason for have a gui for the gateway? What are the default settings?

You can run the Gateway without a GUI. But maybe try with one core only on both VM.

Did you try with other VM on VirtualBox? Like plain vanilla Debian? Does it also freeze?

1 Like

I only use VirtualBox for Whonix. So 192MB RAM and one core on the Gateway is fine? What about video memory? Lowest setting?

I would think if that is okay than 4GB RAM and 3 cores and 128MB video memory should be fine on the workstation?

Forget what I said. Apparently default cores number for VirtualBox is 3. I didn’t remember that since I use KVM. My apologies for misleading you.

Did you try running another virtual machine, such as a vanilla Debian or Ubuntu VM, does it also freeze?

1 Like

I haven’t.

So I have to use 3 cores for both VM’s? Crazy 3 cores for the gateway?

You don’t “have” to do anything. It’s just the default settings. It will probably run with less than 3 cores. I am just trying to figure out the cause of your problem.

Maybe would be a good idea to download another Linux distribution like Ubuntu or Debian or anything else and see how it behaves in VirtualBox. If it also freezes then the problem is not with Whonix.

1 Like

For sure. The freezing is caused by resource allocation so I’m trying to figure out the optimal settings given my laptop specs and use case. I want to know what the lowest I can set for the Gateway without causing issue so I can allocate more to the workstation which on occasion freezes or even crashes. Also the full screen doesn’t work anymore with the workstation.

Whonix is at time of writing tested with Debian buster.

And VirtualBox version 6.1.6.

This might be more important than VM settings.

There is really no special recipe for that.

Whonix-Gateway/Workstation doesn’t require a specific number of CPU cores. 1 should suffice.

One VirtualBox specific limitation: Assign less CPU cores per VM than the host has.
I.e. host has 4 cores, don’t assign more than 3 cores to VM.
https://www.virtualbox.org/ticket/19500
3 cores is default in Whonix stable now.

2 GB RAM for gateway and 2 GB for workstation is already optimal - unless you do something specifically RAM intense.

By responsibilities: Whonix doesn’t produce VirtualBox. Whatever a VM does shouldn’t have a bad effect on the host operating system. Whatever Whonix does must not have any bad influence on the host operating system. VirtualBox is produced by virtualbox.org. If any VM (such as Whonix) would mange to freeze/crash the host operating system that these are virtualizer (VirtualBox) bugs. Therefore:

You could also report a bug against upstream VirtualBox [archive], VirtualBox bugtracker [archive] / VirtualBox forums [archive]. Quote Reasons of vm to get into “aborted” state [archive]

Would you mind sharing with us one of those logs so that we can judge for ourselves? From a machine that got aborted? ZIP it before using the “Upload attachment” at the bottom of your reply form.

  1. VirtualBoxright click a VMShow Log...LogSaveOK
  2. Zip the log.
  3. Report to VirtualBox support.

Related:

NB this is caused by the cpu pinning setting I enable for VMs and can easily be reversed.

Now my Gateway is unable to connect to Tor port with exit code 277.

I really need to access my workstation on Tor I don’t know what it decided to quit working all of a sudden.

Edit: If I increase the RAM to 2GB on the Gateway it runs in GUI and connects. However once I runt he Workstation it aborts the Gateway. If I reload the Gateway it aborts the Workstation.

Do not accidentally substitute Tor for a question related to Tor Browser , as this causes confusion.

Therefore…

I don’t know what that means. See: Sample Bug Report

VirtualBox 6.1.10 (released June 05 2020)

https://www.virtualbox.org/wiki/Changelog-6.1#v10

It contains some GUI related fixes.

Maybe this was caused by VirtualBox version 6.1.8.

VirtualBox aborted bugs, see: https://www.whonix.org/wiki/VirtualBox/Troubleshooting#Aborted

I dropped down to kernel 4.19 and so far the issue has ceased. Guessing it’s a kernel bug as usual.

So I’m thinking the first issue is VitrualBox and Kernel related as I can run both instances on 4.19.

However now the Workstation browser will not run anymore. I have tried running it from cli and running update-torbrowser with no success.

Browser fixed by running update-torbrowser in cli and selecting version.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]