[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Qubes-Whonix 14.0.0.6.9 TemplateVMs for R3.2 and R4--Testers Wanted!

Done.

3 Likes

There r some numerous issues from first look up:- (the test done inside Qubes 3.2)

  • Cant connect to Tor due to this issue:

  • Graphical issue inside Dolphine (maybe xfce nautilus interruption?)


  • Move/Copy to other VMs is not there

1 Like

Thank you for testing, @TNT_BOM_BOM !

Could you please copy and past the output of the following two commands executed in the Whonix-gateway:

sudo --non-interactive /usr/bin/tor --defaults-torrc /usr/share/tor/tor-service-defaults-torrc -f /etc/tor/torrc --RunAsDaemon 0 --verify-config

cat /etc/tor/torrc

1 Like

I have the same issue in Dolphin. I then installed nautilus and the options are available in nautilus.

1 Like

i c , well thats a bug by itself. we cant use xfce stuff mixed with kde because that will expand the surface of attack + its not tested before.

1 Like
  • Remove the Dead project Ricochet = 2 years no voice

The latest version is 1.1.4 (November 5, 2016)

  • Remove KDE-Help inside GW and WS as it might request suspicious requests which could leak potential data
1 Like

mirrors of onion whonix v2 or v3 no hope to connect to them, they r down or so missed.

1 Like

Are we supposed to add reports in this thread?
On Qubes 4.0 rc5, updated from current-testing, after removing sys-whonix, and installing the new templates, sudo qubesctl state.highstate completes, but does not create sys-whonix etc , as is (I assume) the intention.
At least, not for me.

3 Likes

Step 1: Either rename sys-whonix and anon-whonix or remove both VMs.

Two points:

  1. If you use sys-whonix as default netvm, you will first have to change that for all downstream qubes. (In 4.0, changing the default netvm does not seem to change this for all dependent qubes.)
  2. If you use sys-whonix as your updateVM and rely on it for anonymity, then deleting it first and then downloading the new templates will download on clearnet, which is probably not what you want.

I realise this is a draft: how about downloading the templates, then deleting sys-whonix and recreating it? (I haven’t tried this.) I suspect there will be a conflict on template names, so the answer would be:
Clone existing whonix-gw to whonix-gw-13
Shutdown sys-whonix and change template to whonix-gw-13.
Restart sys-whonix
Reinstall Qubes-Whonix templates
etc etc

4 Likes

Damn - good points unman. Normally I test instructions first to make sure they make sense and work properly. @0brand - happy to fix?

3 Likes

I see, the permission on Tor data directory seems to be the problem.

Could you please check if there is any different between the following permissions and yours:

user@host:~$ sudo ls -ld /var/lib/tor
drwx--S--- 2 debian-tor debian-tor 4096 Mar 23 15:33 /var/lib/tor

If there is any different, try fixing it with:

user@host:~$ sudo /usr/bin/install -Z -m 02700 -o debian-tor -g debian-tor -d /var/lib/tor

And then restart the Tor.

If there is still any problem, could you please report the output of this again:

sudo --non-interactive /usr/bin/tor --defaults-torrc /usr/share/tor/tor-service-defaults-torrc -f /etc/tor/torrc --RunAsDaemon 0 --verify-config

Thank you!

2 Likes

done everything = still the same

1 Like

The owner and group was pulse and sdwate which have been corrected to debian-tor and debian-tor . Tor says: Configuration was valid.

I think Tor should run well now.

For restarting the Tor, you can try either using the desktop shortcut or:
user@host:~$ systemctl restart tor@default.service

To verify tor really works:

user@host:~$ systemctl status tor@default.service 
● tor@default.service - Anonymizing overlay network for TCP
   Loaded: loaded (/lib/systemd/system/tor@default.service; static; vendor preset: 
  Drop-In: /lib/systemd/system/tor@default.service.d
           └─30_qubes.conf, 40_obfs4proxy-workaround.conf, 40_qubes.conf, 50_contro
   Active: active (running) since Fri 2018-03-23 16:51:17 UTC; 5s ago              
  Process: 5675 ExecStartPost=/bin/kill -HUP ${MAINPID} (code=exited, status=0/SUCC
  Process: 5670 ExecStartPre=/usr/bin/tor --defaults-torrc /usr/share/tor/tor-servi
  Process: 5665 ExecStartPre=/usr/bin/install -Z -m 02755 -o debian-tor -g debian-t
 Main PID: 5672 (tor)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/system-tor.slice/tor@default.service
           └─5672 /usr/bin/tor --defaults-torrc /usr/share/tor/tor-service-defaults 

I usually also use arm to see the established circuits for verification, too.

1 Like

I am curious what could be the cause of this. Did you anyone else encounter the same issue?

1 Like

BTW, I personally sometimes prefer posting text than posting pictures because:

  1. easy for searching so that the error discussion may be helpful for people in the future
  2. easy to quote, so that we can have a better context in discussion
  3. reveal less info: info like time or metadata in the picture can be obscured or avoided.
1 Like

still not working

do think i have a choice ? maybe u forgot that there is no way to shift text or anything from whonix to any other place. so im taking screenshots for the problems and then move them from Qubes to other VM. sorry if thats bothers u but no way to solve for now unless this going to be fixed in the next release or doing a working it.

2 Likes

The first draft of the instructions was mirroring the Whonix-13 call for tester blog post (with a few edits). Those instructions told readers to follow the steps in the Qubes manual reistallatioin method debian to install Templates (which I tested-worked). Unfortunately I made edits to the draft after it was posted which made the instruction invalid.

@torjunkie this one is on me. I should have went through the draft after edits to make sure the instructions were still sound. Not only that I should have combined the instructions into one page. Lesson learned.

@unman Thanks for taking the time to go through the draft and point those issues out. Much appreciated!

ATM editing the draft to include all steps on one page and fixing mistakes i.e. umans suggestions. Also testing instructions before they are posted.

Thanks again unman!!

3 Likes

Well, it is another problem this time.

I never met this problem before. Let’s wait for @Patrick and see what’s his opinion on this?


Sorry I did not realize there was a problem. The shift+control+c trick has been working fine for me.

1 Like

It was not clear that it is a draft discussion for a to-be-released blog post. If it was, true. So let’s just continue here.

Next time:

  • please chose a very clear subject to make sure it is a blog post draft discussion, not the actual testing discussion
  • same for forum post text

No big deal, similar stuff happens to me all the time.


Needs

sudo qubesctl state.sls qvm.anon-whonix

( https://www.whonix.org/wiki/Dev/Qubes#salt )

Related:
https://github.com/QubesOS/qubes-issues/issues/3447

1 Like

more problems:-

DisableNetwork 0

is not added by default to /usr/local/etc/torrc.d/50_user.torrc

and if u add it , then u will receive this message:-

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]