[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Qubes 3, trouble with installing whonix portal

On a brand new HD, after installing the newest stable Qubes 3 OS, I found the code for installing whonix gateway.
sudo qubes-dom0-update --enablerepo=qubes-templates-community qubes-template-whonix-gw qubes-template-whonix-ws

Has this been updated ? There are several stories and I’m not sure being a new Linux user. The first attempt failed due to the OS being unable to find adequate mirror. My second attempt produced this: VM: PCI device 02:00.0 does not exist (domain sys-net), I don’t know what it means, any help would be greatly appreciated.

Thank you in advance

What stories? Similar to yours?

That can happen from time to time.

use lspci in dom0 Konsole to figure out what that device is. Probably network adapter but could be graphics, usb, etc.

Do you have network connectivity at all?

Qubes App Menu -> sys-net -> launch Terminal
ping -c 3 fedoraproject.org

  1. If no network, search terms “fedora [your network adapter]”
  2. still need help, ask http://fedoraforum.org/
  3. still need help, ask https://groups.google.com/forum/#!forum/qubes-users

If your network is working, update your TemplateVMs and dom0 and try to get Whonix Templates again.

entr0py:

1spci:
command not found

ping -c 3 fedoraproject.org:
unknown host

I have a black fedora VM with updates pending.

This is a complicated little bugger. It must be a network card issue, just built a desktop machine to try out Qubes and I have a HD slide so that I can use Linux Mint along side any other OS that I choose easily. (1) But, first I used a USB network connectivity device from ASUS and the speed and connection was too slow. (2) So I got another regular long range network card with antenna for inside the box. I started many years ago with Knoppix but I’m not a regular Linux user sorry to say, but I really like Mint. I fell in love with the Qubes-Whonix concept, I mean who wouldn’t but I didn’t realize the complexity level, is the best way to put it I guess. I went this way to avoid Win 10 and that lunatic asylum.

I’m going to try the USB again and see if I have connectivity.

Can you recommend a good network card that will work the first time out of the box ?

Thank you for the help, tc

Realised wrong code:
lspci:
network controller:
Ralink corp. RT5392 PCIe
wireless network adapter 03:00.0
ethernet controller:
Realtek Semiconductor Co., Ltd. RTL8111/8168/8411P
CI Express Gigabit Ethernet Controller (rev 0c)

tried everything again it’s the network card, it needs a PCI device that works.

lspci

not

1spci

These are Qubes, not Whonix issues. This is difficult to see when you’re
new. Don’t worry. The sys-net related issue certainly is Qubes specific.
And qubes-dom0-update and Qubes mirrors are Qubes specific also.

Meaning, contacting the Qubes support is the better place to get help
with this.

Thank you Patrick

Hope this helps someone with the same issue…

To install Whonix, you must have a working Qubes machine already.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]