[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Problems upgrading from 15 to 16

I recently got the notice when I booted up my whonix gateway that it’s release, 15.0.0.8.9 wasn’t supported, so I downloaded and tried to install ver 16.0.3.1, but am having problems.

First it told me that ver 16 wouldn’t work on my Virtualbox ver, so I tried to update that and found that for some reason it wouldn’t work on my version of linux mint. So after a lot of fun I got Mint upgraded, then upgraded VB, and now am finally back to trying to get ver16 of whonix to work.

When I start up either the gateway or the workstation it runs for about a minute, and I have a black box that says “/dev/sdai: clean, 111732/655536000 files, 1341314/25213632 blocks”, and it just hangs there.

When I look in the logs I can see things like this:
VMMDev: Guest Log: 16:17:25.819601 main vbglRGuestCtrlDetectPeekGetCancelSupport: Not Supported (#3)
and
timesync Error: vgsvcTimeSyncWorker: VbglR3GetHostTime failed; rc2=VERR_NOT_SUPPORTED
and
VMMDev: Guest Log: Failed to get display change request, rc=VERR_NOT_IMPLEMENTED
Service Terminated Abnormally with VERR_NOT_IMPLEMENTED

Those are all the errors that I can see that look like obvious errors.

I’ve compared all of the settings for the Ver 16 machines to the 15 versions, and the settings are exactly the same, (those boot fine, but give me the deprecated warning).

I’ve also tried playing with the ver 16 settings to add a little more vram, scale factor and even tried enabling 3d acceleration, but no luck. Same with all the system settings.

Just for giggles and grins I blew away the new ver 16 machines, then redownloaded whonix and reimported the appliance, but that didn’t help either.

Is there anything I have to do to the Mint OS to get ver 16 to work? Or is there anything else fundamentally different about ver 16 that I need to do differently?

Thanks for any and all help!


Thanks for the link, but a quick question. Is that the most up to date version of the file?

The reason I ask is this part:
VirtualBox VMSVGA Graphics Controller Setting Workaround

If it still does not work, a final option is the following.

Inside the virtual machine [[8]](ht

On the host:

  1. Power off the VM.

  2. VirtualBoxclick a VMSettingsDisplayGraphics ControllerVMSVGAOK (This is already the case in newer Whonix ™ versions.)

  3. VirtualBoxclick a VMSettingsDisplayGraphics Controllerincrease slider for Video Memory to 128OK (This is already the case in newer Whonix ™ versions.)

  4. Restart the VM.

  5. Maximize the VM window after start of the VM as soon as possible.

  6. If necessary, try again one of above workarounds.Workaround 1: Try Other VirtualBox Virtual Graphics Controller Settings

  7. Power off the VM.

  8. VirtualBoxclick a VMSettingsDisplayGraphics ControllerVMSVGAOK (Or try other settings there.) [9]

  9. VirtualBoxclick a VMSettingsDisplayGraphics Controllerincrease slider for Video Memory to 128OK (This is already the default in recent releases of Whonix ™.)

  10. Restart the VM.

When I check my settings I don’t have a “Graphics Controller” section. I have Screen, Remote Display, and Video Capture.

It feels like this is something video related, but I can’t see any way to change the video resolution except for the scale setting, and that seems more just like a zoom in feature.

Thanks again for your help.

After you click on Display, there is a drop down menu Graphics Controller.

It is under the default Screen tab.

Screen | Remote Display | Recording

Stay with the default Screen tab.

The Graphics Controller setting is there.

Also this.

Ugh, this thing won’t let me upload a picture of what I see on my screen. I think my version must be different than your because I see:

Screen, Remote Display, Video Capture as the tabs. Under Screen I see:

Video Memory: slider bar going from 0mb to 128mb. Currently set at 16
Monitor Count: slider from 1 to 8, currently set at 1
Scale Factor: slider from 100% to 200%, currently set at 100%
Acceleration: Checkbox to enable 3d acceleration, currently not checked.

The only other things on this page are Cancel and Ok. There is nothing that says anything about Screen Resolution, (and I looked on the other two tabs as well).

Uploading Images for Support

Here is what I see:
https://anonfiles.com/ffdbn7Yfu2/Capture_PNG

For some reason I can’t download that picture, but if I click on the broken window icon it does show up on anonfiles.

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]