[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Problems Installing Whonix KVM

I’m installing Whonix in virt-manager on Ubuntu 20.04. I am able to run the VM after doing the steps for Arch users to fix a blkio error. When I run the VM, though, it says “Boot failed: not a bootable disk.” What should I do to troubleshoot this? I extracted the qcow2 files, moved them to the new location, and did the setup with the XML files.

Thanks

Hi. try adding a virtual cdrom to the VM and see if it boots? Someone with a similar problem tried that.

1 Like

Thanks for the reply but I am still having trouble. I added this to the XML by doing sudo virsh edit Whonix-Workstation:

<disk type='file' device='cdrom'> <driver name='qemu' type='raw'/> <source file='/var/lib/libvirt/images/Whonix-Workstation.qcow2'/> <target dev='hdc' bus='sata'/> <readonly/> <address type='drive' controller='0' bus='0' target='0' unit='2'/> </disk>

Adding this got me a different error: Error starting domain: internal error: process exited while connecting to monitor: 2020-06-26T23:33:17.274796Z qemu-system-x86_64: -device ide-cd,bus=sata0.2,drive=libvirt-1-format,id=sata0-0-2: Failed to get shared "write" lock Is another process using the image [/var/lib/libvirt/images/Whonix-Workstation.qcow2]?

Did I do the right thing? I’m not quite sure what you mean by “try adding a virtual cdrom to the VM”

Thanks

Much easier to add via VMM. Won’t cause confusion whether you added the right syntax or not.

I suggested you add a virtual cd drive using VMM to the vM and then try starting it. If that doesn;t work then there is probably something buggy about your virtualization packages. I would recommend you switch to a tested and stable setup using Debian for host OS or report the bug to your current distro and wait for a fix.

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]