[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Problem with suspending. timesync works only via tor, but tor requeres time to be synchronized


#1

After long gatweway’ suspending (‘Save state’) clocks becomes unsynchronized, tor is also disconnected (moreover #service networking restart must be done after resume to make virtual adapters work, atleast on windows’s vbox).

Tor can’t establish connections because of (/var/log/tor/log):
[warn] Our clock is x hours, xx minutes behind the time published in the consensus network status document (2016-06-01 21:00:00 UTC). Tor needs an accurate clock to work correctly. Please check your time and date settings!

But time cannot be synchronized automatically with tymesync (/var/log/sdwdate.log):
Tor is not yet fully bootstrapped. 25 % done. Tor reports: NOTICE BOOTSTRAP PROGRESS=25 TAG=loading_status SUMMARY=Loading networkstatus consensus

This is vicious circle: tor requres timesync, but timesync requres active tor connection. Only full restart (power off -> on) or manual time adjustment helps.


#2

It’s a known issue.

https://www.whonix.org/wiki/Non-Qubes-Whonix_Known_bugs#Suspend_.2F_Hibernate_Issues

Help welcome.


#3

How can i return the vbox’s timesync feature then?
Deactivated sdwdate (https://www.whonix.org/wiki/Advanced_Security_Guide#Disable_Automatic), changed ‘/etc/init.d/virtualbox-guest-utils.anondist’ (removed --disable-timesync key),
Did vboxmanage setextradata "Whonix-Gateway" "VBoxInternal/Devices/VMMDev/0/Config/GetHostTimeDisabled" 0.
But all of this didn’t help.
Thanks.


#4

dead project


#5

Doing that is unsupported. ( https://www.whonix.org/wiki/Unsupported )