[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Problem with guest additions whonix gateway and workstation

I started with a fresh install both whonix gateway and workstation. Did sudo apt get and dist upgrade, inserted iso file and… Nothing happened. I tried doing the same on a fresh install of linux mint and a cd popped up on my desktop and started the auto run process. Searching google tried probably everything with no solution. Can someone please help me?

Hi o10767761

Your’re having problems mounting iso images? Did you try this workaround?

https://www.whonix.org/wiki/Known_Issues#Mounting_.28CD_.2F_DVD.29_Devices

1 Like

VirtualBox guest additions are installed by default in Whonix.

https://www.whonix.org/wiki/VirtualBox/Guest_Additions#Installed_by_Default

No manual installation required.

Installation from iso / CD is discouraged.

https://www.whonix.org/wiki/VirtualBox/Guest_Additions#Installation_from_VirtualBox_CD

And should not be required.

Ok thanks for the info. Can you tell me why doesnt the guest os window resize? Whonix XFCE bug solution not working

I don’t have a solution for that unfortunately.

so i was trying to fix something that will not work :smiley: im okay with that, i thought that the problem with that was that i didnt have guest additions.
Is there any other version that will work with scaliing etc? I see 2 versions to download, one with the XFCE and one with the non graphics, but that wont work i guess

The CLI version doesn’t scale for sure. If you could make that work, that would be superb. Haven’t seen that ever.

For the CLI version I even failed to even figure out how to increase the desktop resolution at all for the VirtualBox version.

Well, you an try getting newer VirtualBox version and/or guest addition. That might help. But it’s undocumented/unsupported.

And this could be sorted out as per https://www.whonix.org/wiki/Free_Support_Principle.

Please contribute.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]