Problem with aapanel installation

Hi guys
I want to install aapanel on Whonix but it doesn’t recognize the download and install command. I don’t know which version of Whonix i’m using, however i downloaded it at the end of 2022 and make the upgrades every time i run it.
Should i download the .ova file again and try again?
On the latest Ubuntu version i tested, you install and aapanel works fine.
Any help and suggestion?
Thank you in advance.

Probably same as on Debian. Needs to be resolved as per:

Please compare with Debian stable.

systemcheck --verbose --function show_versions
1 Like

Good morning.
I tried on Debian 12 and aapanel downloads and the installation is done normally. I checked the Whonix version i was using and it was the 16. I deleted it and downloaded the latest version in case the problem is there and i tried. The result is exactly as with the old version i had. I also asked on various forums and they told me that the server might block me because of ntp or because i am through a tor network. Below i give you what the terminal returns to me.

workstation user ~]% wget -O link/script/ && bash aapanel
–2023-08-12 22:04:10-- link/script/
Resolving link (link)…
Connecting to link (link)||:80… connected.
HTTP request sent, awaiting response… 403 Forbidden
2023-08-12 22:04:10 ERROR 403: Forbidden.

zsh: exit 8 wget -O link/script/
workstation user ~]%

The server is blocking Tor looks like.


That is what I believe.
I downloaded the .sh file from the link and i don’t remember which commands we run through terminal to try if something happens.

Contact the server.


Good morning.
I contacted aapanel support about my problem and they told me this:

“Hello, it should be a problem with zsh, it is recommended to use bash as the shell parser of the system.”

If someone knows what i need to do to fix the problem and can recommend a guide with technical advice, that would be great. Whonix is the safest OS for setting up self-hosted .onion servers and aapanel is open source and recommended for such use by major tor hosting providers. So i think that whatever we manage with this problem that i am facing, it will help others in the future who wish to follow my method.
Again thank you for participating.



Then run the installation command.

Then contact support again.

1 Like

Not an zsh issue but please do as @extraextra said anyhow because this remains to be proven to the support.

Hello again.
After many tests, i discovered that indeed the problem is found in the Whonix Workstation due to the many libraries missing from the system.
I also tested with Kicksecure, and while it did the installation normally, when I went to download the server of my choice, my browser threw me a list full of errors from missing libraries. I installed Debian 12 on the Virtual Box and passed it through the Whonix Gateway and everything was done and works perfectly.
Eventually the problem was solved in this way.

If it works on Kicksecure it should work on Whonix too.

Are you using old version Whonix 16? That might be the reason.

Should work on Whonix 17 if it works on Kicksecure 17.

All versions of distributions are the most recent. With Whonix Workstation and Kickseure, installation normally starts only outside the tor network. In Whonix almost halfway through the installation flies bugs. In Kicksecure while the installation is done normally, when you log in with the browser in the panel and go to install the packages you are interested in, then you see a window that shows a bunch of errors and you can not proceed. In Debian 12, however, you can log in to tor and do the installation normally, and then everything works flawlessly, just like in Ubuntu. The only difference I found between Debian and Ubuntu is that in the latter the installation is faster because there are probably some libraries pre-installed that are required to work.

However, what I write on this subject in no way means that Whonix is not one of the most important works of anonymity. Whonix has proven its worth to us daily for years, just its design and construction is not intended for this kind of server, the simple installations I have done with Nginx, PHP, MySQL, PhpMyAdmin work fine.

Did you check your Whonix version?

Yes, Whonix-Xfce-

What error does Whonix show that Kicksecure does not?


@extraextra On Whonix 17 the installation can only be done outside the tor network, but when you connect to the panel it produces errors for missing libraries and files and does not work. In Kicksecure 17 can be installed via tor, but again encounters the same problem when connecting to the panel. I spoke again with the technical department of aapanel and from what one developer told me, it is probably because these OS have a hard kernel compared to regular versions of Debian and some packages that the console needs to work have been removed. I don’t mind though because my work turned out fine after connecting Debian 12 to Whonix Gateway and everything works flawlessly.