Problem update after upgrade from 15 to 16

Hello. I have problem after i upgrade my WS and GW from 15 to 16 whonix.
When i start update via system trey, in Qubes Updater i see error: "Rendering SLS ‘base:update.qubes-vm’ failed: Jinja variable ‘dict object’ has no attribute ‘os_family’.
This happens to all templates with WS 16 and GW 16.
I have clear WS 16 template and with my settings - doesn’t matter. Also i tested with other templates - debian 10, whonix 15 - all ok. And from terminal in whonix 16 i can update correct.
How i can fix it?

remove and install fresh isnt that better? (surely by understanding and following the wiki steps as well)

Hello, welcome back!

This error message isn’t part of any Whonix source code.
Qubes updater isn’t developer by Whonix.
It’s a Qubes issue. Not a Whonix issue.

See: What to post in this Qubes-Whonix forum and what not.

sudo apt update
sudo apt upgrade
type in templates terminal, for me worked

But I received this message only after upgrading from version 15 to 16. It is fundamentally difficult to suggest what could have happened? It happened only to me and has some kind of individual bug or it happens to all?

I don’t understand why they can’t help with that here, it’s all one infrastructure, qubes+whonix…

I already wrote in the first post that this method works, but I have a lot of templates with Whonix 16 and it is not convenient to open the console every time for each. Automatic updates used to be a super feature, but that’s broken now. I can’t find a single mention on the internet of a similar problem.


It’s because I am not a developer of Qubes dom0, Qubes updater, Qubes salt and Qubes developers cannot monitor all the posts here or integrate it into their workflows. Qubes and Whonix are separate projects. From Qubes-Whonix existence doesn’t follow that there was a total fusion of all infrastructure and knowledge.

I am not aware of other reports of the same issue.

I solved the problem. It turned out that you need to download fedora-34 template, and change the default-mgmt-dvm to fedora 34 in the template manager. It turned out to be not difficult, but no one told me:( Okay. One little question, I know it doesn’t apply to qubes-whonix either, but it doesn’t require a detailed explanation. When upgrading from 15 to 16, the pre-installed 15 template cannot be renamed/deleted. Is there a solution or just ignore it?

Upd: solved this problem too. Qube troubleshooting | Qubes OS

qvm-prefs template-vm-name installed_by_rpm false

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]