[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Problem making virtual machine drive read-only for Live mode

I am trying to use Whonix in Live mode in VirtualBox. When I followed the pertinent VirtualBox instructions to set the drive read-only, it said to run this command:

VBoxManage setextradata Whonix-Workstation-XFCE “VBoxInternal/Devices/lsilogicsas/0/LUN#0/AttachedDriver/Config/ReadOnly” 1

I encountered this error when trying to start the virtual machine:

Failed to construct device ‘lsilogicsas’ instance #0 (VERR_PDM_CFG_MISSING_DRIVER_NAME).

Result Code:
NS_ERROR_FAILURE (0x80004005)
Component:
ConsoleWrap
Interface:
IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

There is another post in ‘Support’ (which I cannot link to) that details the same problem, and suggests changing the controller type to ACHI in the virtual machine settings. However this did not work.

Ubuntu 18.04
VirtualBox version: 6.1.22 r144080
Whonix version: 15.0.1.9.3

A post was merged into an existing topic: Live VM Problems

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]