please help with shared folders

I am trying to get a shared folder on KVM Whonix, but it gives a permission error.
I see in the documentation to chmod the folder, and I did this. But it persists.

I saw a youtube video on how to do this. Try using a removable drive as the shared folder source but when I tried it. I tried mounting the drive with veracrypt as an encrypted drive after encrypting it. The steps are:

  1. Change the view from console to details.
  2. Add hardware from which you should select filesystem.
  3. Change driver to virtio-9p.
  4. In source path select browse.
  5. Now select the storage location.
  6. Press Browse Local.
  7. Select the folder you want as your source path.
  8. Under target path type “/shared_data”.
  9. Select Finish.
  10. Boot up the Workstation.
  11. In the terminal do “mkdir ~/shared”.
  12. Then type “sudo mount -t 9p -o trans-virtio /shared_data ~/shared”.
  13. To unmount type “sudo umount /shared_data ~/shared”.
1 Like

thank you but
I’m stuck on the “Change driver to virtio-9p.”
As the choices for Driver under filesystem are: handle, path, and default

Try all the options one by one.