[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Permission Denied trying to save torrc file


#1

Hello Whonix communtiy need some help with my whonix gateway, I’m trying to add tor bridges and everytime I save the torrc file I get permission denied. To be more specific [ Error writing /etc/tor/torrc: Permission denied ]

Here is how my file looks like

This file is part of Whonix

Copyright © 2012 - 2013 adrelanos

See the file COPYING for copying conditions.

Use this file for your user customizations.

Please see /etc/tor/torrc.examples for help, options, comments etc.

Anything here will override Whonix’s own Tor config customizations in

/usr/share/tor/tor-service-defaults-torrc

Enable Tor through whonixsetup or manually uncomment “DisableNetwork 0” by

removing the # in front of it.

#DisableNetwork 0
UseBridges 1

ClientTransportPlugin obfs2,obfs3 exec /usr/bin/obfsproxy managed

ClientTransportPlugin obfs4 exec /usr/bin/obfs4proxy managed
bridge obfs4 {Redacted } cert=[Also Redacted]$
bridge obfs4 [Redacted] cert=[Also Redacted]
bridge obfs4 [Redacted] cert=[Also Redacted]

right when I go about saving, and hitting enter, I always get permission denied. Do I need to change the default user and password on whonix first? I have not done that yet.


#2

What method/command did you use to open Tor config?

https://www.whonix.org/wiki/Tor#Edit_Tor_Configuration ?


#3

Clicked on konsole and went to “nano /etc/tor/torrc” and got into the file that way. Just recently just went from the Graphical Interface and clicked on “Tor User config”, I put in all my bridges and then Tor stopped working after I saved the file.


#4

Hi SpeechName3

As per: https://www.whonix.org/wiki/Tor#Edit_Tor_Configuration

From Whonix 14 onwards, all user unique Tor configurations should be stored in /usr/local/etc/torrc.d/50_user.conf and not anywhere else.

To save torrc configuration options.

In Whonix-Gateway konsole, open torrc in an editor.

sudo nano /usr/local/etc/torrc.d/50_user.conf

Add options.

Save and exit.

Reload Tor

sudo systemctl reload tor@default

Run whonixcheck

whonixcheck


#5

Just did this and got,

Error writing /usr/local/etc/torrc.d/50_user.conf: No such file or directory


#6

@SpeechName3 r u using whonix 14? or 13?


#7

In case of Whonix 13…

Whonix 14 required.


#8

You guys were right, I upgraded to Whonix 14 and that solved that permission denied error, now I’m getting a new error from Tor actually working.

So basically the I’m getting is this

[warn]Strange ClientTransportPlugin type ‘obfs3’
[warn] Failed to parse/validate config: Invalid client transport line. See logs for details.
[err] Reading config failed–see warnings above.

Any help with that?


#9

I would start fresh. Its possible a mistake was made. Remove all Tor user configurations (torrc) and start from the beginning.


#10

Close thread! I got it to work!