[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

perl: warning: Setting locale failed


#1

utf issue back again. because there is no more en_US.UTF-8?

there is en_US.UTF-8 UTF-8 only, and this is the default of debian stretch i have.


perl: warning: Setting locale failed.
#2

Also happened to me. No changes by Whonix that could cause this. Perhaps this is caused by any changes by Debian or Qubes?

@marmarek any idea?


#3

mostly debian , i checked it with plain debian and it was having the same change.


#4

You mean, this issue is also happening in the Qubes Debian template?

Also in plain, non-Qubes Debian if you are by chance also a user of that?


#5

I have both debians, in Debian-Qubes it seems that the package locales-all is installed , so even if you try to reconfigure the language through dpkg you will not find any language been used though it doesnt show any error. and thats mostly the package fix it.

For plain debian on non-qubes i have it but it has only en_US.UTF-8 UTF-8

So i think the case is that Debian jessie to stretch changed that or that was one of the changes, but it seems didnt changed with whonix case. or it was an update from 9.x to 9.x and included that fix but in whonix didnt work for some reason.

So fixation is easy i think , just use the new codename for it.


#6

#7

On my system, locales package (along with rest of glibc suite) got upgraded in February

locales:amd64 (2.24-11+deb9u3, 2.24-11+deb9u4)

https://tracker.debian.org/news/1029134/accepted-glibc-224-11deb9u4-source-into-proposed-updates-stable-new-proposed-updates/

Maybe related?

In my /var/log/apt/term.log from my routine update (this is in Whonix WS template)

[...snip...]
Setting up locales (2.24-11+deb9u4) ...
Generating locales (this might take a while)...
Generation complete.
[...snip...]
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

I don’t see the last 3 warnings in my debian-9 templates from the same version update. Perhaps because of locales-all?


#8

mig5 via Whonix Forum:

Perhaps because of locales-all?

Most likely yes. locales-all is a good workaround for useres if one
can afford the ~ 100 MB extra disk space but since Whonix is included on
Qubes installer iso, we ought to find a solution that works without the
package.