Passwordless root prompt at boot

I followed the instructions on Qubes OS to add a GUI prompt for root, it looks like it works fine despite the documentation being outdated. Some of the files to edit and remove are no longer present at all ← unrelated.


or clearnet

I now get the prompt at boot mentioned at the bottom of the page, I created the file /etc/sudoers.d/zz99 and I still got it. I tried changing whonixcheck to systemcheck as I believe it changed name, still got it. How would I prevent this from happening at present time?

At time of writing this isn’t officially supported by Qubes. Quote:

Replacing passwordless root access with Dom0 user prompt

While ITL supports the statement above, some Qubes users may wish to enable user/root isolation in VMs anyway. We do not support it in any of our packages, but of course nothing is preventing the user from modifying his or her own system. A list of steps to do so is provided here without any guarantee of safety, accuracy, or completeness. Proceed at your own risk. Do not rely on this for extra security.

Qubes ticket:

Therefore unsupported at Whonix.

1 Like

Solved by reverting changes.