[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Package manager stuck running whonixcheck won't work

Hello I am running whonix12 on Ubuntu using Virtualbox everything has been working fine until recently. When I run the Gateway it does the swdate sync but it doesn’t go to #2 connect to tor or #3 whonix check instead it gives me a message saying:

"A package manager (such as apt-get) is currently running. Waiting for it to finish…
If you are not aware of any package managers running exit now, find out if there are any issues with dpkg or apt-get. Run in the terminal for example:
sudo dpkg --audit
sudo dpkg --configure -a
and several other commands all of which I have tried.

When I run the workstation I am still able to connect to tor although I am uncomfortable doing so with this message as I fear I am missing a whonixcheck update. I am very new to this can someone please help me get my whonix working normally?? The above paragraph was typed as I could not copy and paste the message but to answer what it says I have no managers running so I have been exiting and just running tor. How can I solve this problem?? Would uninstalling and reinstalling whonix 12 fix it?? PLEASE ADVISE.

Thanks in advance.

Worth noticing, whonxicheck is reporting a symptom. It’s not the cause of the issue.

Does this message persist after reboot?

Stop whonixcheck. Try updating that VM as usual. As per
https://www.whonix.org/wiki/Update

Then you will likely run into some package manager issue which can be fixed as per:
https://www.whonix.org/wiki/Support#Free_Support_Principle

Yes it persists after reboot and I recently updated VB, would uninstalling and reinstalling whonix 12 possibly fix this??

Unfortunately I can’t find the proposed solution in your second link can you please specify??

Likely.

It’s unspecific. It’s basically saying “same as in Debian” and then explaining what that means. It’s not a solution but directions to help yourself.

I have the same problem.

I tryed updating the VM, and even removing and installing gateway and workstation all over again but the message keep coming back.

The problem is that before, the gateway told me always when its time to update, but now never. It only shows this about the package manager that never loads.

im worried that my anonymity is in danger because of that?

Is it unsafe to surf in the workstation?

How do i get rid of this problem?

whoisnix:

im worried that my anonymity is in danger because of that?

No need for that.
–> https://www.whonix.org/wiki/FAQ#Should_I_be_concerned_about…_.3F

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]