Onionshare won't launch on Whonix 16 [SOLVED]

Hi @,

I followed the Wiki and wanted to install OnionShare :

Unfortunately, OnionShare doesn’t start and I get this message :

I tried repeating all the procedure again with no success.

OnionShare is also here

But when double-clicking it, the mouse is looping and I don’t get any message.

Is there a way to uninstall and reinstall it again as it can maybe help? Or any other solution, I am a bit desperate here…

Thanks for your help.

EDIT 1 : In addition I would let you know that as I first started OnionShare after the installation it started but then crashed at 10% when it was loading. Since than I have not been able to get back the launching process.

EDIT 2: followed up the official installation command line Flathub—An app store and build service for Linux but it didn’t fix that issue.

EDIT 3 : SOLVED with the help of @Micah. Thank you so much Sir.

That issue doesn’t happen for me, probably fixed in Whonix - for VirtualBox - Point Release! (just now released). Probably also fixed after upgrades.

Happened to me, How did you solve it?

Hello @TNT_BOM_BOM !
Delete the file ~/.config/onionshare/lock. If you don’t have any persistent onionshare services you could delete the whole onionshare config folder. Then try running onionshare again.
This is how I solved that particular issue.
Let me know if that helped you :wink:

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]