[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

onionizing qubes repo and apt-transport-https

two qubestions, if you please.

important info:
a. i have installed apt-transport-tor and apt-transport-https in all templates.
b. i still have all templates using sys-whonix-14 as updatevm.
c. yes, i (believe that i) know this is redundant.

  1. qubes repo v2 is incredibly slow when i update. it takes hours.
    qubes repo v3 says there is no release file.
    i want to onionize. debian and whonix v2 and v3 are good. but qubes.onions are not.

please help? i do not understand.

sudo nano /etc/apt/sources.list.d/qubes-r4.list

Main qubes updates repository

#deb [arch=amd64] tor+http://deb.qubes-os.org/r4.0/vm stretch main
#deb-src tor+http://deb.qubes-os.org/r4.0/vm stretch main
#deb [arch=amd64] tor+http://deb.qubesos4rrrrz6n4.onion/r4.0/vm stretch main
deb [arch=amd64] tor+http://deb.sik5nlgfc5qylnnsr57qrbm64zbdx6t4lreyhpon3ychmxmiem7tioad.onion stretch main

  1. apt-transport-https does not work on onion sites. such as either debian repo.

Err:6 tor+https://vwakviie2ienjx6t.onion/debian stretch Release
gnutls_handshake() failed: The TLS connection was non-properly terminated.

is that normal? should i not use https on onion sites?

thankyouthankyou thank you.

dom0 onion update:

https://yum.qubesosrrrrz6n4.onion/r4.0/current/dom0/fc25/repodate/repomd.xml: [Errno 14] curl#7 - "Couldn’t connect"
Trying other mirror.
https://yum.qubesosrrrrz6n4.onion/r4.0/templates-itl/repodate/repomd.xml: [Errno 14] curl#7 - "Couldn’t connect"
Trying other mirror.

EDIT im ok here. https is not ok. http works.

also, it seems like it may be faster now. i havent tried in a month the qubes v2 onion. it seem maybe fast now.

v3 still not working.

Does the above need to be tor+http://deb.sik5nlgfc5qylnnsr57qrbm64zbdx6t4lreyhpon3ychmxmiem7tioad.onion/r4.0/vm stretch main
instead?

https://www.whonix.org/wiki/Security_Guide#Onionizing_Repositories

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]