not able to log into Whonix in Virtualbox


Dear Folks, i really need some help

I will try to write down the issue as exactly as possible

I normally opened Whonix, everything was as usual, after, i decided to open an existing database in Keepass2, which returned an error saying something like “could not open specified file, file is corrupted”. So i tried to open the file in repair mode as described on the Support-site of Keepass 2.
This could not solve my problem, but i found a Thread with a problem similar to mine, which came to the solution to simply update everything. So i tried > sudo-apt get update and > sudo apt-get dist-upgrade on both, Workstation and Gateway. Still not able to open the file, so i decided to restart my laptop and try again.
Now i opened the Virtualbox and started both the Workstation and the Gateway at the same time as usual. But now, on the workstation there appeared a Site I’ve never seen

The Site has the normal Whonix background, in the middle there is a grey window saying welcome to debian at host
On the left Side i can choose some entries like ''Anonymous remailer master, backup, bin, daemon etc…", on the right side i could input an username and a password, but it doesn’t accept my username and password.

If someone could help me to log into my Whonix again, I’d be really thankful, because I have like all of my passwords in the Keepass inside my Whonix-Workstation.

Thank you for your help


username: user
password: changeme
(changeme is the default. If you changed it, use your password.)

Does that work?


Good day,

Could you perhaps upload a screenshot to help us better understand the issue?

Have a nice day,



Hey, thank you for the fast responses

I tried [quote=“Patrick, post:2, topic:3283”]
username: userpassword: changeme

it gave back this error


But it’s enough for recovery purposes, you can now use file manager, konsole, etc.?

Looks like you installed some additional package? A gui package related to unity?


no it seems like the only thing i can do is to click on ok, which leads me back to the page i was before.
about the additional package, i’m not sure about that, but i don’t think so


In the page you were before look for a session type setting. Choose KDE or KDE failsafe or something called like that. That may allow successful login.


tried to login with both KDE Plasma Workspace and failsafe and got back the same error as before


Hard to fix. Only as per free support principle.
( https://www.whonix.org/wiki/Free_Support_Principle )

Probably best to start over with a newly imported Whonix-Workstation and then avoiding into getting this mess again (installing alternative gui packages).

A virtual console could be used for data recovery purposes.
( https://www.whonix.org/wiki/Desktop#Virtual_Consoles )

This could also be happening due to disk corruption (hardware failure).


Once logged into a virtual console, it might help to rename the KDE data dirs in the home folder. Perhaps if you login again KDE will work (starting with defaults again). Uncertain. It might also help to undo the packages (you may have) installed that lead to this issue.


Maybe this is a duplicate of the following thread?



It seems like this could be the same error as mine, yes
And after reading the other Thread, it might be possible that i used autoremove shortly before this issue happened.
I tried to open a virtual console using RightCtrl+F1 to fix eventual broken dependecies like you suggested, but this doesn’t seem to work either because i can’t open the virtual console
I also exported the workstation to prevent further damage like you said in the other Thread

any suggestions why the virtual console doesn’t work or how to proceed?



Do you generally know how to get into a virtual console? I mean, can you take any fully functional (new) Whonix VM and get into a virtual console there? If the answer is…

  • no -> figure that out first
  • yes, but it does not work in the broken VM…

use rads:

Or total hack, lower the amount of the VMs RAM to let’s say 400 MB. Then no gui will start and you will more likely to log into a virtual console (since nothing else is offered then).


No, I’m not able to open a virtual console, checked it on the working Gateway and nothing seems to happen.
I reduced the RAM on the Workstation and started again, now there is this console like you said. Any Commands you could recommend to fix this problem and get Whonix to work properly again?


It’s HostKey + FnKey. By default HostKey is Right (not Left) Control.

Unknown splash screen logon

If that doesn’t work, set up a Shared Folder as documented here:


Copy out your Keepass database and any important data. Import a new Workstation. Once it’s running properly, smash the old one to bits (or keep it as backup).


Tried the commands described in

There are a lot of things going on in the console but it results in the same situation as before. If i set the Ram below 400 MB, Whonix will start into a Console, if i set the RAM higher I’m at the same Screen i started on.

Set up a shared folder now as you advised. I’m like 99% sure all the data I need from the Workstation is in one folder. So now i need to move that folder into my shared folder using the console Assuming I know the path of the folder i need, this should be possible right?


Hey everyone

I was able to find and extract my data using the shared folder function. It looks like everything went well, although i did not test the Keepass-Database yet but it seems my Whonix-related problems are solved for now.

Here is how i could find and copy my data, if it is of any use to anyone

I setup the Shared Folder as described in here

After that, i got into the Console in my Workstation and used find . -iname new\* to search for the Document i wanted to find, because i knew the name was something like NewDatabase, and there it was, NewDatabase.kdbx, the file i searched for.

Next i used readlink -f NewDatabase.kdbx to get the full path of the Document, which was /home/user/Documents/NewDatabase.kdbx

Having found the full path of my Database, and knowing there were a couple of other Documents in the Folder i decided to copy the whole Folder Documents into the Shared Folder using sudo cp -R /home/user/Documents /mnt/shared
Now what’s left to do is to setup a new Whonix-Workstation, which i definitely will do tomorrow, and hoping i don’t get into such a situation again…

Anyway, thank you @Patrick, @entr0py for your big help, as a newbie I learned a lot, really appreciate it.
Have a nice Day