[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Not able to adjust display resolution in KVM and late password prompt during login


#1

Not able to the virtual machine window to scale fullscreen.

The instructions were this on the KVM-whonix page
Virt-Manager Whonix-Workstation window -> View -> Scale Display -> Always | Check: Auto resize VM with window
But those options are not clickable and are not getting enabled. Is there any other settings i should look for ?

After i start the workstation it takes me to desktop screen and for few minutes i am able to perform tasks and only after those few minutes the login screen suddenly shows up(undoing the tasks ofc) . Is there any way to avoid this huge lag ?


#2

Question: are you running the default Debian kernel (in Whonix)? I saw this with newer kernel versions I compiled for guests. If the former is true then its a libvirt bug only.

I reported this upstream but in vain. Because we are a virtualized OS we have the misfortune of running into these bugs before everyone else.

This is another problem recently fixed upstream but unfortunately it will take some time to come into Debian stable.

It was so annoying that we created a package that fixes it. Please follow the instructions to install the qxl-xorg-enhance package:


BTW what libvirt/KVM versions are you running?


#3

Thanks for the information about qxl-xorg-enhance.

  1. yes i am running the default kernel in whonix (whatever came along with).
    ws- 3.16.0-4-686-pae
    gw- 3.16.0-4-686-pae

  2. Name: qemu-kvm Version: 2.3.1-15.1
    Name: virt-manager Version: 1.2.1-7.2

PS:Still not able to get fullscreen scale on VM


#4

ok the fullscreen option doesn’t seem to work under KDE, just tried them in two other DE’s where it seems to be working fine and i am able to select the options under W-S window -> View options.


#5

Interesting. Thanks for looking into it. Are those DEs on the host or Whonix?


#6

Host DE’s .