[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Noscript got disabled

See https://forums.informaction.com/viewtopic.php?f=7&t=25529. Looks wide spread.

1 Like

Looks like it’s more accurate to say one of Mozilla’s intermediate certs expired, which caused a lot of addons to get disabled including Noscript. https://bugzilla.mozilla.org/show_bug.cgi?id=1548973

1 Like

Please report to the Tor Project if seeing this in Tor Browser

Happened to me too. In TorBrowser.

Its been reported.

https://trac.torproject.org/projects/tor/ticket/19907

Ah, that explains that clusterF (thought I was being targeted by the Eye of Sauron for the 50th time :slight_smile: )

Since it completely disables NoScript in Tor Browser, which is a major issue, one (pretty unsafe) workaround in the interim for NoScript functionality:

  1. about:config
  2. change xpinstall.signatures.required to false

You’ll be warned that NoScript can’t be verified in the interim and to use cautiously yada yada, but that is better than a completely disabled, essential addon… pretty disappointing stuff from Mozilla as cert currency is pretty basic stuff.

Alternatively:

  1. about:config
  2. enable.javascript = true
    change to
    enable.javascript=false
1 Like

This was a nice demonstration how much power remote computers at Mozilla / certificate authories / whoever have over us. If they were to flip some buttons, XYZ happened at our local computers. Without even installing upgrades. Without anyone being aware and warning of this beforehand?

I don’t know how bad trusting firefox signing is compared to Debian packaged addons. The fact it has to be resigned regularly just makes it very brittle.

1 Like